SUSE-SU-2022:2839-1
SUSE-SU-2022:2839-1 · Security update for podman
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for podman fixes the following issues: Updated to version 3.4.7: - CVE-2022-1227: Fixed an issue that could allow an attacker to publish a malicious image to a public registry and run arbitrary code in the victim's context via the 'podman top' command (bsc#1182428). - CVE-2022-27191: Fixed a potential crash via SSH under specific configurations (bsc#1197284). - CVE-2022-21698: Fixed a potential denial of service that affected servers that used Prometheus instrumentation (bsc#1196338).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
podman SUSE:Linux Enterprise Module for Containers 15 SP3
- Affected ranges
- ECOSYSTEM: < 3.4.7-150300.9.9.2
Update to 3.4.7-150300.9.9.2
podman SUSE:Linux Enterprise Micro 5.1
- Affected ranges
- ECOSYSTEM: < 3.4.7-150300.9.9.2
Update to 3.4.7-150300.9.9.2
podman SUSE:Linux Enterprise Micro 5.2
- Affected ranges
- ECOSYSTEM: < 3.4.7-150300.9.9.2
Update to 3.4.7-150300.9.9.2
podman SUSE:Enterprise Storage 7.1
- Affected ranges
- ECOSYSTEM: < 3.4.7-150300.9.9.2
Update to 3.4.7-150300.9.9.2
podman openSUSE:Leap 15.3
- Affected ranges
- ECOSYSTEM: < 3.4.7-150300.9.9.2
Update to 3.4.7-150300.9.9.2
Original sources
- https://www.suse.com/support/update/announcement/2022/suse-su-20222839-1/
- https://bugzilla.suse.com/1182428
- https://bugzilla.suse.com/1196338
- https://bugzilla.suse.com/1197284
- https://www.suse.com/security/cve/CVE-2022-1227
- https://www.suse.com/security/cve/CVE-2022-21698
- https://www.suse.com/security/cve/CVE-2022-27191
- https://osv.dev/vulnerability/SUSE-SU-2022:2839-1