SUSE-SU-2023:3233-1
SUSE-SU-2023:3233-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: Update to version 2.40.5 (bsc#1213905): - CVE-2023-38133: Fixed information disclosure. - CVE-2023-38572: Fixed Same-Origin-Policy bypass. - CVE-2023-38592: Fixed arbitrary code execution. - CVE-2023-38594: Fixed arbitrary code execution. - CVE-2023-38595: Fixed arbitrary code execution. - CVE-2023-38597: Fixed arbitrary code execution. - CVE-2023-38599: Fixed sensitive user information tracking. - CVE-2023-38600: Fixed arbitrary code execution. - CVE-2023-38611: Fixed arbitrary code execution. Update to version 2.40.3 (bsc#1212863): - CVE-2023-32439: Fixed a bug where processing maliciously crafted web content may lead to arbitrary code execution. (bsc#1212863) - CVE-2023-32435: Fixed a bug where processing web content may lead to arbitrary code execution. (bsc#1212863) - CVE-2022-48503: Fixed a bug where processing web content may lead to arbitrary code execution. (bsc#1212863)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Manager Proxy 4.2
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Manager Server 4.2
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
webkit2gtk3 SUSE:Enterprise Storage 7.1
- Affected ranges
- ECOSYSTEM: < 2.40.5-150200.78.1
Update to 2.40.5-150200.78.1
Original sources
- https://www.suse.com/support/update/announcement/2023/suse-su-20233233-1/
- https://bugzilla.suse.com/1212863
- https://bugzilla.suse.com/1213905
- https://www.suse.com/security/cve/CVE-2022-48503
- https://www.suse.com/security/cve/CVE-2023-32435
- https://www.suse.com/security/cve/CVE-2023-32439
- https://www.suse.com/security/cve/CVE-2023-38133
- https://www.suse.com/security/cve/CVE-2023-38572
- https://www.suse.com/security/cve/CVE-2023-38592
- https://www.suse.com/security/cve/CVE-2023-38594
- https://www.suse.com/security/cve/CVE-2023-38595
- https://www.suse.com/security/cve/CVE-2023-38597
- https://www.suse.com/security/cve/CVE-2023-38599
- https://www.suse.com/security/cve/CVE-2023-38600
- https://www.suse.com/security/cve/CVE-2023-38611
- https://osv.dev/vulnerability/SUSE-SU-2023:3233-1