SUSE-SU-2023:4294-1
SUSE-SU-2023:4294-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 ships missing Lang packages to SUSE Linux Enterprise 15 SP4 and SP5. Security fixes: - CVE-2023-41993: Fixed an issue where processing malicious web content could have lead to arbitrary code execution (bsc#1215661). - CVE-2023-39928: Fixed a use-after-free that could be exploited to execute arbitrary code when visiting a malicious webpage (bsc#1215868). - CVE-2023-41074: Fixed an issue where processing malicious web content could have lead to arbitrary code execution (bsc#1215870). Other fixes: - Fixed missing package dependencies (bsc#1215072).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.2
Update to 2.42.1-150400.4.57.2
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.2
Update to 2.42.1-150400.4.57.2
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.2
Update to 2.42.1-150400.4.57.2
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.2
Update to 2.42.1-150400.4.57.2
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.3
Update to 2.42.1-150400.4.57.3
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.3
Update to 2.42.1-150400.4.57.3
webkit2gtk3 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.2
Update to 2.42.1-150400.4.57.2
webkit2gtk3-soup2 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.2
Update to 2.42.1-150400.4.57.2
webkit2gtk4 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.3
Update to 2.42.1-150400.4.57.3
webkit2gtk3 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.2
Update to 2.42.1-150400.4.57.2
webkit2gtk3-soup2 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.2
Update to 2.42.1-150400.4.57.2
webkit2gtk4 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 2.42.1-150400.4.57.3
Update to 2.42.1-150400.4.57.3
Original sources
- https://www.suse.com/support/update/announcement/2023/suse-su-20234294-1/
- https://bugzilla.suse.com/1214093
- https://bugzilla.suse.com/1214640
- https://bugzilla.suse.com/1214835
- https://bugzilla.suse.com/1215072
- https://bugzilla.suse.com/1215661
- https://bugzilla.suse.com/1215866
- https://bugzilla.suse.com/1215867
- https://bugzilla.suse.com/1215868
- https://bugzilla.suse.com/1215869
- https://bugzilla.suse.com/1215870
- https://bugzilla.suse.com/1216483
- https://www.suse.com/security/cve/CVE-2023-35074
- https://www.suse.com/security/cve/CVE-2023-39434
- https://www.suse.com/security/cve/CVE-2023-39928
- https://www.suse.com/security/cve/CVE-2023-40451
- https://www.suse.com/security/cve/CVE-2023-41074
- https://www.suse.com/security/cve/CVE-2023-41993
- https://osv.dev/vulnerability/SUSE-SU-2023:4294-1