SUSE-SU-2023:4339-1
SUSE-SU-2023:4339-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: - CVE-2023-41993: Fixed an issue where processing malicious web content could have lead to arbitrary code execution (bsc#1215661). - CVE-2023-39928: Fixed a use-after-free that could be exploited to execute arbitrary code when visiting a malicious webpage (bsc#1215868). - CVE-2023-41074: Fixed an issue where processing malicious web content could have lead to arbitrary code execution (bsc#1215870). Non-security fixes: - Fixed missing package dependencies (bsc#1215072).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Manager Proxy 4.2
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Manager Server 4.2
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Enterprise Storage 7
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
webkit2gtk3 SUSE:Enterprise Storage 7.1
- Affected ranges
- ECOSYSTEM: < 2.42.1-150200.87.4
Update to 2.42.1-150200.87.4
Original sources
- https://www.suse.com/support/update/announcement/2023/suse-su-20234339-1/
- https://bugzilla.suse.com/1213379
- https://bugzilla.suse.com/1213581
- https://bugzilla.suse.com/1215072
- https://bugzilla.suse.com/1215661
- https://bugzilla.suse.com/1215866
- https://bugzilla.suse.com/1215867
- https://bugzilla.suse.com/1215868
- https://bugzilla.suse.com/1215869
- https://bugzilla.suse.com/1215870
- https://bugzilla.suse.com/1216483
- https://www.suse.com/security/cve/CVE-2023-32393
- https://www.suse.com/security/cve/CVE-2023-35074
- https://www.suse.com/security/cve/CVE-2023-37450
- https://www.suse.com/security/cve/CVE-2023-39434
- https://www.suse.com/security/cve/CVE-2023-39928
- https://www.suse.com/security/cve/CVE-2023-40451
- https://www.suse.com/security/cve/CVE-2023-41074
- https://www.suse.com/security/cve/CVE-2023-41993
- https://osv.dev/vulnerability/SUSE-SU-2023:4339-1