SUSE-SU-2023:4561-1
SUSE-SU-2023:4561-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: Update to version 2.42.2 (bsc#1217210): - CVE-2023-41983: Processing web content may lead to a denial-of-service. - CVE-2023-42852: Processing web content may lead to arbitrary code execution. Already previously fixed: - CVE-2022-32919: Visiting a website that frames malicious content may lead to UI spoofing (fixed already in 2.38.4). - CVE-2022-32933: A website may be able to track the websites a user visited in private browsing mode (fixed already in 2.38.0). - CVE-2022-46705: Visiting a malicious website may lead to address bar spoofing (fixed already in 2.38.4). - CVE-2022-46725: Visiting a malicious website may lead to address bar spoofing (fixed already in 2.38.4). - CVE-2023-32359: A user’s password may be read aloud by a text-to-speech accessibility feature (fixed already in 2.42.0).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk3 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk3-soup2 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk4 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk3 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk3-soup2 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
webkit2gtk4 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 2.42.2-150400.4.64.2
Update to 2.42.2-150400.4.64.2
Original sources
- https://www.suse.com/support/update/announcement/2023/suse-su-20234561-1/
- https://bugzilla.suse.com/1217210
- https://www.suse.com/security/cve/CVE-2022-32919
- https://www.suse.com/security/cve/CVE-2022-32933
- https://www.suse.com/security/cve/CVE-2022-46705
- https://www.suse.com/security/cve/CVE-2022-46725
- https://www.suse.com/security/cve/CVE-2023-32359
- https://www.suse.com/security/cve/CVE-2023-41983
- https://www.suse.com/security/cve/CVE-2023-42852
- https://osv.dev/vulnerability/SUSE-SU-2023:4561-1