SUSE-SU-2024:1444-1
SUSE-SU-2024:1444-1 · Security update for php7
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php7 fixes the following issues: - CVE-2024-2756: Fixed bypass of security fix applied for CVE-2022-31629 that lead PHP to consider not secure cookies as secure (bsc#1222857) - CVE-2024-3096: Fixed bypass on null byte leading passwords checked via password_verify (bsc#1222858)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7 SUSE:Linux Enterprise Module for Legacy 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7-fastcgi SUSE:Linux Enterprise Module for Legacy 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7-fpm SUSE:Linux Enterprise Module for Legacy 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
apache2-mod_php7 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7-embed openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7-fastcgi openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7-fpm openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1
php7-test openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.34.1
Update to 7.4.33-150400.4.34.1