SUSE-SU-2024:1446-1
SUSE-SU-2024:1446-1 · Security update for php8
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php8 fixes the following issues: - CVE-2024-2756: Fixed bypass of security fix applied for CVE-2022-31629 that lead PHP to consider not secure cookies as secure (bsc#1222857) - CVE-2024-3096: Fixed bypass on null byte leading passwords checked via password_verify (bsc#1222858)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
apache2-mod_php8 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8-embed openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8-fastcgi openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8-fpm openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1
php8-test openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.40.1
Update to 8.0.30-150400.4.40.1