p PatchFirst

SUSE-SU-2024:1944-1

SUSE-SU-2024:1944-1 · Security update for webkit2gtk3

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This update for webkit2gtk3 fixes the following issues: - Update to version 2.44.2 (bsc#1225071): - CVE-2024-23252: Fixed a vulnerability where processed web content may lead to a denial-of-service. (bsc#1222010) - CVE-2024-23254: Fixed a vulnerability where a malicious website may exfiltrate audio data cross-origin. (bsc#1222010) - CVE-2024-23263: Fixed a vulnerability where processed maliciously crafted web content may prevent Content Security Policy from being enforced. (bsc#1222010) - CVE-2024-23280: Fixed a vulnerability where a maliciously crafted webpage may be able to fingerprint the user. (bsc#1222010) - CVE-2024-23284: Fixed a vulnerability where processed maliciously crafted web content may prevent Content Security Policy from being enforced. (bsc#1222010) - CVE-2023-42950: Fixed a vulnerability where processed maliciously crafted web content may lead to arbitrary code execution. (bsc#1222010) - CVE-2023-42956: Fixed a vulnerability where processed web content may lead to a denial-of-service. (bsc#1222010) - CVE-2023-42843: Fixed a vulnerability where visiting a malicious website may lead to address bar spoofing. (bsc#1222010) - CVE-2024-27834: Fixed a vulnerability where an attacker with arbitrary read and write capability may be able to bypass Pointer Authentication. (bsc#1225071)

Fix available

Published
Updated

Stack: system

Affected products and versions

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.44.2-150600.12.3.1

    Update to 2.44.2-150600.12.3.1

  • webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.44.2-150600.12.3.1

    Update to 2.44.2-150600.12.3.1

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.44.2-150600.12.3.1

    Update to 2.44.2-150600.12.3.1

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.44.2-150600.12.3.1

    Update to 2.44.2-150600.12.3.1

  • webkit2gtk3 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.44.2-150600.12.3.1

    Update to 2.44.2-150600.12.3.1

  • webkit2gtk3-soup2 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.44.2-150600.12.3.1

    Update to 2.44.2-150600.12.3.1

  • webkit2gtk4 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.44.2-150600.12.3.1

    Update to 2.44.2-150600.12.3.1

Original sources

Check your server →