p PatchFirst

SUSE-SU-2024:2037-1

SUSE-SU-2024:2037-1 · Security update for php7

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This update for php7 fixes the following issues: - CVE-2024-2756: Fixed bypass of security fix applied for CVE-2022-31629 that lead PHP to consider not secure cookies as secure (bsc#1222857) - CVE-2024-3096: Fixed bypass on null byte leading passwords checked via password_verify (bsc#1222858) - CVE-2024-5458: Fixed an issue that allows to bypass filters in filter_var FILTER_VALIDATE_URL. (bsc#1226073)

Fix available

Published
Updated

Stack: system

Affected products and versions

  • php7 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Affected ranges
    • ECOSYSTEM: < 7.4.33-150200.3.65.1

    Update to 7.4.33-150200.3.65.1

  • php7 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Affected ranges
    • ECOSYSTEM: < 7.4.33-150200.3.65.1

    Update to 7.4.33-150200.3.65.1

  • php7 SUSE:Linux Enterprise Server 15 SP2-LTSS

    Affected ranges
    • ECOSYSTEM: < 7.4.33-150200.3.65.1

    Update to 7.4.33-150200.3.65.1

  • php7 SUSE:Linux Enterprise Server 15 SP3-LTSS

    Affected ranges
    • ECOSYSTEM: < 7.4.33-150200.3.65.1

    Update to 7.4.33-150200.3.65.1

  • php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP2

    Affected ranges
    • ECOSYSTEM: < 7.4.33-150200.3.65.1

    Update to 7.4.33-150200.3.65.1

  • php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP3

    Affected ranges
    • ECOSYSTEM: < 7.4.33-150200.3.65.1

    Update to 7.4.33-150200.3.65.1

  • php7 SUSE:Enterprise Storage 7.1

    Affected ranges
    • ECOSYSTEM: < 7.4.33-150200.3.65.1

    Update to 7.4.33-150200.3.65.1

Original sources

Check your server →