SUSE-SU-2024:3664-1
SUSE-SU-2024:3664-1 · Security update for php8
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php8 fixes the following issues: - CVE-2024-8925: Fixed erroneous parsing of multipart form data in HTTP POST requests leads to legitimate data not being processed (bsc#1231360) - CVE-2024-8927: Fixed cgi.force_redirect configuration is bypassable due to an environment variable collision (bsc#1231358) - CVE-2024-9026: Fixed pollution of worker output logs in PHP-FPM (bsc#1231382)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
apache2-mod_php8 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8-embed openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8-fastcgi openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8-fpm openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
php8-test openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 8.0.30-150400.4.46.1
Update to 8.0.30-150400.4.46.1
Original sources
- https://www.suse.com/support/update/announcement/2024/suse-su-20243664-1/
- https://bugzilla.suse.com/1231358
- https://bugzilla.suse.com/1231360
- https://bugzilla.suse.com/1231382
- https://www.suse.com/security/cve/CVE-2024-8925
- https://www.suse.com/security/cve/CVE-2024-8927
- https://www.suse.com/security/cve/CVE-2024-9026
- https://osv.dev/vulnerability/SUSE-SU-2024:3664-1