SUSE-SU-2024:4146-1
SUSE-SU-2024:4146-1 · Security update for php7
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php7 fixes the following issues: - CVE-2024-11233: Single byte overread with convert.quoted-printable-decode filter (bsc#1233702). - CVE-2024-11234: Configuring a proxy in a stream context might allow for CRLF injection in URIs (bsc#1233703). - CVE-2024-8929: Leak partial content of the heap through heap buffer over-read (bsc#1233651).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7 SUSE:Linux Enterprise Module for Legacy 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-fastcgi SUSE:Linux Enterprise Module for Legacy 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-fpm SUSE:Linux Enterprise Module for Legacy 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7 SUSE:Linux Enterprise Module for Legacy 15 SP6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-fastcgi SUSE:Linux Enterprise Module for Legacy 15 SP6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-fpm SUSE:Linux Enterprise Module for Legacy 15 SP6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
apache2-mod_php7 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-embed openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-fastcgi openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-fpm openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-test openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
apache2-mod_php7 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-embed openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-fastcgi openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-fpm openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
php7-test openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.43.1
Update to 7.4.33-150400.4.43.1
Original sources
- https://www.suse.com/support/update/announcement/2024/suse-su-20244146-1/
- https://bugzilla.suse.com/1233651
- https://bugzilla.suse.com/1233702
- https://bugzilla.suse.com/1233703
- https://www.suse.com/security/cve/CVE-2024-11233
- https://www.suse.com/security/cve/CVE-2024-11234
- https://www.suse.com/security/cve/CVE-2024-8929
- https://osv.dev/vulnerability/SUSE-SU-2024:4146-1