p PatchFirst

SUSE-SU-2024:4215-1

SUSE-SU-2024:4215-1 · Security update for php8

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This update for php8 fixes the following issues: - CVE-2024-11233: buffer overread when processing input with the convert.quoted-printable-decode filter. (bsc#1233702) - CVE-2024-11234: possible CRLF injection in URIs when a proxy is configured in a stream context. (bsc#1233703) - CVE-2024-8929: data exposure on MySQL clients due to heap buffer overread in mysqlnd. (bsc#1233651)

Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • apache2-mod_php8 openSUSE:Leap 15.5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8 openSUSE:Leap 15.5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8-embed openSUSE:Leap 15.5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8-fastcgi openSUSE:Leap 15.5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8-fpm openSUSE:Leap 15.5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

  • php8-test openSUSE:Leap 15.5

    Affected ranges
    • ECOSYSTEM: < 8.0.30-150400.4.49.1

    Update to 8.0.30-150400.4.49.1

Original sources

Check your server →