SUSE-SU-2024:4292-1
SUSE-SU-2024:4292-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: - CVE-2024-44308: Fixed processing maliciously crafted web content that may lead to arbitrary code execution (bsc#1233631) - CVE-2024-44309: Fixed data isolation bypass vulnerability (bsc#1233632)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.46.3-150600.12.21.1
Update to 2.46.3-150600.12.21.1
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.46.3-150600.12.21.1
Update to 2.46.3-150600.12.21.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.46.3-150600.12.21.1
Update to 2.46.3-150600.12.21.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.46.3-150600.12.21.1
Update to 2.46.3-150600.12.21.1
webkit2gtk3 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.46.3-150600.12.21.1
Update to 2.46.3-150600.12.21.1
webkit2gtk3-soup2 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.46.3-150600.12.21.1
Update to 2.46.3-150600.12.21.1
webkit2gtk4 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.46.3-150600.12.21.1
Update to 2.46.3-150600.12.21.1