SUSE-SU-2024:4349-1
SUSE-SU-2024:4349-1 · Security update for libsoup2
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for libsoup2 fixes the following issues: - CVE-2024-52530: Fixed HTTP request smuggling via stripping null bytes from the ends of header names (bsc#1233285) - CVE-2024-52531: Fixed buffer overflow via UTF-8 conversion in soup_header_parse_param_list_strict (bsc#1233292) - CVE-2024-52532: Fixed infinite loop while reading websocket data (bsc#1233287)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libsoup2 SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Manager Proxy 4.3
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 SUSE:Manager Server 4.3
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 openSUSE:Leap Micro 5.5
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
libsoup2 openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.3.1
Update to 2.74.2-150400.3.3.1
Original sources
- https://www.suse.com/support/update/announcement/2024/suse-su-20244349-1/
- https://bugzilla.suse.com/1233285
- https://bugzilla.suse.com/1233287
- https://bugzilla.suse.com/1233292
- https://www.suse.com/security/cve/CVE-2024-52530
- https://www.suse.com/security/cve/CVE-2024-52531
- https://www.suse.com/security/cve/CVE-2024-52532
- https://osv.dev/vulnerability/SUSE-SU-2024:4349-1