SUSE-SU-2025:0096-1
SUSE-SU-2025:0096-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
This update for webkit2gtk3 fixes the following issues: Update to version 2.46.5 (bsc#1234851): Security fixes: - CVE-2024-54479: Processing maliciously crafted web content may lead to an unexpected process crash - CVE-2024-54502: Processing maliciously crafted web content may lead to an unexpected process crash - CVE-2024-54505: Processing maliciously crafted web content may lead to memory corruption - CVE-2024-54508: Processing maliciously crafted web content may lead to an unexpected process crash - CVE-2024-54534: Processing maliciously crafted web content may lead to memory corruption Other fixes: - Fix the build with GBM and release logs disabled. - Fix several crashes and rendering issues. - Improve memory consumption and performance of Canvas getImageData. - Fix preserve-3D intersection rendering. - Fix video dimensions since GStreamer 1.24.9. - Fix the HTTP-based remote Web Inspector not loading in Chromium. - Fix content filters not working on about:blank iframes. - Fix several crashes and rendering issues.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.46.5-150400.4.103.1
Update to 2.46.5-150400.4.103.1
Original sources
- https://www.suse.com/support/update/announcement/2025/suse-su-20250096-1/
- https://bugzilla.suse.com/1234851
- https://www.suse.com/security/cve/CVE-2024-40866
- https://www.suse.com/security/cve/CVE-2024-44185
- https://www.suse.com/security/cve/CVE-2024-44187
- https://www.suse.com/security/cve/CVE-2024-44308
- https://www.suse.com/security/cve/CVE-2024-44309
- https://www.suse.com/security/cve/CVE-2024-54479
- https://www.suse.com/security/cve/CVE-2024-54502
- https://www.suse.com/security/cve/CVE-2024-54505
- https://www.suse.com/security/cve/CVE-2024-54508
- https://www.suse.com/security/cve/CVE-2024-54534
- https://osv.dev/vulnerability/SUSE-SU-2025:0096-1