p PatchFirst

SUSE-SU-2025:01864-1

SUSE-SU-2025:01864-1 · Security update for libsoup2

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This update for libsoup2 fixes the following issues: - CVE-2025-4948: Fixed integer underflow in soup_multipart_new_from_message() leading to denial of service (bsc#1243332) - CVE-2025-4969: Fixed off-by-one out-of-bounds read may lead to infoleak (bsc#1243423) - CVE-2025-32906: Fixed out of bounds reads in soup_headers_parse_request() (bsc#1241263) - CVE-2025-32909: Fixed NULL pointer dereference in the sniff_mp4 function in soup-content-sniffer.c (bsc#1241226) - CVE-2025-32910: Fixed null pointer deference on client when server omits the realm parameter in an Unauthorized response with Digest authentication (bsc#1241252) - CVE-2025-32911: Fixed double free on soup_message_headers_get_content_disposition() via 'params'. (bsc#1241238) - CVE-2025-32912: Fixed NULL pointer dereference in SoupAuthDigest (bsc#1241214) - CVE-2025-32913: Fixed NULL pointer dereference in soup_message_headers_get_content_disposition (bsc#1241162)

Fix available

Published
Updated

Stack: system

Affected products and versions

  • libsoup2 SUSE:Linux Enterprise Micro 5.3

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise Micro 5.4

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise Micro 5.5

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise Server 15 SP5-LTSS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Manager Proxy 4.3

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

  • libsoup2 SUSE:Manager Server 4.3

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.9.1

    Update to 2.74.2-150400.3.9.1

Original sources

Check your server →