SUSE-SU-2025:03225-1
SUSE-SU-2025:03225-1 · Security update for cups-filters
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for cups-filters fixes the following issues: - CVE-2024-47175: no validation of IPP attributes in `ppdCreatePPDFromIPP2` when writing to a temporary PPD file allows for the injection of attacker-controlled data to the resulting PPD (bsc#1230932).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
cups-filters SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise Server 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Manager Proxy LTS 4.3
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Manager Server LTS 4.3
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters SUSE:Enterprise Storage 7.1
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1
cups-filters openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 1.25.0-150200.3.22.1
Update to 1.25.0-150200.3.22.1