SUSE-SU-2025:03270-1
SUSE-SU-2025:03270-1 · Security update for krb5
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for krb5 fixes the following issues: - CVE-2025-3576: weakness in the MD5 checksum design allows for spoofing of GSSAPI-protected messages that are using RC4-HMAC-MD5 (bsc#1241219). Krb5 as very old protocol supported quite a number of ciphers that are not longer up to current cryptographic standards. To avoid problems with those, SUSE has by default now disabled those alorithms. The following algorithms have been removed from valid krb5 enctypes: - des3-cbc-sha1 - arcfour-hmac-md5 To reenable those algorithms, you can use allow options in krb5.conf: [libdefaults] allow_des3 = true allow_rc4 = true to reenable them.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
krb5 SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 1.20.1-150500.3.17.1
Update to 1.20.1-150500.3.17.1