SUSE-SU-2025:0775-1
SUSE-SU-2025:0775-1 · Security update for podman
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for podman fixes the following issues: - CVE-2025-27144: Fixed denial of service in parsing function of embedded library Go JOSE (bsc#1237641) - CVE-2024-9676: github.com/containers/storage: Fixed symlink traversal vulnerability in the containers/storage library can cause Denial of Service (DoS) (bsc#1231698) - CVE-2024-9675: Fixed cache arbitrary directory mount in buildah (bsc#1231499) - CVE-2024-9407: Fixed Improper Input Validation in bind-propagation Option of Dockerfile RUN --mount Instruction in buildah (bsc#1231208) - CVE-2024-9341: cri-o: FIPS Crypto-Policy Directory Mounting Issue in containers/common Go Library (bsc#1231230) - CVE-2024-1753: Fixed full container escape at build time in buildah (bsc#1221677) - CVE-2024-11218: Fixed a container breakout by using --jobs=2 and a race condition when building a malicious Containerfile. (bsc#1236270) - CVE-2024-6104: Fixed hashicorp/go-retryablehttp writing sensitive information to log files (bsc#1227052) - CVE-2023-45288: Fixed golang.org/x/net/http2 excessive resource consumption when receiving too many headers (bsc#1236507) - Load ip_tables and ip6_tables kernel module (bsc#1214612) * Required for rootless mode as a regular user has no permission to load kernel modules - Refactor network backend dependencies: * podman requires either netavark or cni-plugins. On ALP, require netavark, otherwise prefer netavark but don't force it. * This fixes missing cni-plugins in some scenarios * Default to netavark everywhere where it's available
Fix available
- Published
- Updated
Stack: system
Affected products and versions
podman SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 4.9.5-150300.9.43.1
Update to 4.9.5-150300.9.43.1
podman SUSE:Linux Enterprise Server 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 4.9.5-150300.9.43.1
Update to 4.9.5-150300.9.43.1
podman SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Affected ranges
- ECOSYSTEM: < 4.9.5-150300.9.43.1
Update to 4.9.5-150300.9.43.1
podman SUSE:Linux Enterprise Micro 5.1
- Affected ranges
- ECOSYSTEM: < 4.9.5-150300.9.43.1
Update to 4.9.5-150300.9.43.1
podman SUSE:Linux Enterprise Micro 5.2
- Affected ranges
- ECOSYSTEM: < 4.9.5-150300.9.43.1
Update to 4.9.5-150300.9.43.1
podman SUSE:Enterprise Storage 7.1
- Affected ranges
- ECOSYSTEM: < 4.9.5-150300.9.43.1
Update to 4.9.5-150300.9.43.1
Original sources
- https://www.suse.com/support/update/announcement/2025/suse-su-20250775-1/
- https://bugzilla.suse.com/1214612
- https://bugzilla.suse.com/1215807
- https://bugzilla.suse.com/1215926
- https://bugzilla.suse.com/1217828
- https://bugzilla.suse.com/1221677
- https://bugzilla.suse.com/1227052
- https://bugzilla.suse.com/1231208
- https://bugzilla.suse.com/1231230
- https://bugzilla.suse.com/1231499
- https://bugzilla.suse.com/1231698
- https://bugzilla.suse.com/1236270
- https://bugzilla.suse.com/1236507
- https://bugzilla.suse.com/1237641
- https://www.suse.com/security/cve/CVE-2023-45288
- https://www.suse.com/security/cve/CVE-2024-11218
- https://www.suse.com/security/cve/CVE-2024-1753
- https://www.suse.com/security/cve/CVE-2024-6104
- https://www.suse.com/security/cve/CVE-2024-9341
- https://www.suse.com/security/cve/CVE-2024-9407
- https://www.suse.com/security/cve/CVE-2024-9675
- https://www.suse.com/security/cve/CVE-2024-9676
- https://www.suse.com/security/cve/CVE-2025-27144
- https://osv.dev/vulnerability/SUSE-SU-2025:0775-1