p PatchFirst

SUSE-SU-2025:0974-1

SUSE-SU-2025:0974-1 · Security update for webkit2gtk3

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This update for webkit2gtk3 fixes the following issues: - CVE-2025-24201: Fixed out-of-bounds write vulnerability due to that WebGL context primitive restart can be toggled from WebContent process (bsc#1239547).

Fix available

Published
Updated

Stack: system

Affected products and versions

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.46.6-150600.12.30.2

    Update to 2.46.6-150600.12.30.2

  • webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.46.6-150600.12.30.2

    Update to 2.46.6-150600.12.30.2

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.46.6-150600.12.30.2

    Update to 2.46.6-150600.12.30.2

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6

    Affected ranges
    • ECOSYSTEM: < 2.46.6-150600.12.30.2

    Update to 2.46.6-150600.12.30.2

  • webkit2gtk3 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.46.6-150600.12.30.2

    Update to 2.46.6-150600.12.30.2

  • webkit2gtk3-soup2 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.46.6-150600.12.30.2

    Update to 2.46.6-150600.12.30.2

  • webkit2gtk4 openSUSE:Leap 15.6

    Affected ranges
    • ECOSYSTEM: < 2.46.6-150600.12.30.2

    Update to 2.46.6-150600.12.30.2

Original sources

Check your server →