SUSE-SU-2025:1149-1
SUSE-SU-2025:1149-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: - CVE-2024-44192: Fixed unexpected process crash due to processing maliciously crafted web content (bsc#1239863) - CVE-2024-54467: Fixed information disclosure via data cross-origin exfiltration due to a cookie management issue (bsc#1239864) Other fixes: - Update to version 2.48.0: + Move tiles rendering to worker threads when rendering with the GPU. + Fix preserve-3D intersection rendering. + Added new function for creating Promise objects to JavaScripotCore GLib API. + The MediaRecorder backend gained WebM support (requires at least GStreamer 1.24.9) and audio bitrate configuration support. + Fix invalid DPI-aware font size conversion. + Bring back support for OpenType-SVG fonts using Skia SVG module. + Add metadata (title and creation/modification date) to the PDF document generated for printing. + Propagate the font’s computed locale to HarfBuzz. + The GPU process build is now enabled for WebGL, but the web process is still used by default. The runtime flag UseGPUProcessForWebGL can be used to use the GPU process for WebGL. + Security fixes: CVE-2024-44192, CVE-2024-54467, CVE-2025-24201. - Disable speech synthesis. It has been disabled until now, and we don't have flite or spiel in SLE. - Add gcc13-PIE to BuildRequires (bsc#1239950). - Backport upstream patch to stop using IOChannel in NetworkCache: hopefully fixes crashes in the network process.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.48.0-150600.12.33.1
Update to 2.48.0-150600.12.33.1
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.48.0-150600.12.33.1
Update to 2.48.0-150600.12.33.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.48.0-150600.12.33.1
Update to 2.48.0-150600.12.33.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.48.0-150600.12.33.1
Update to 2.48.0-150600.12.33.1
webkit2gtk3 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.48.0-150600.12.33.1
Update to 2.48.0-150600.12.33.1
webkit2gtk3-soup2 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.48.0-150600.12.33.1
Update to 2.48.0-150600.12.33.1
webkit2gtk4 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.48.0-150600.12.33.1
Update to 2.48.0-150600.12.33.1
Original sources
- https://www.suse.com/support/update/announcement/2025/suse-su-20251149-1/
- https://bugzilla.suse.com/1239863
- https://bugzilla.suse.com/1239864
- https://bugzilla.suse.com/1239950
- https://www.suse.com/security/cve/CVE-2024-44192
- https://www.suse.com/security/cve/CVE-2024-54467
- https://www.suse.com/security/cve/CVE-2025-24201
- https://osv.dev/vulnerability/SUSE-SU-2025:1149-1