SUSE-SU-2025:1331-1
SUSE-SU-2025:1331-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: - Update to version 2.48.1 - CVE-2024-54551: improper memory handling may lead to a denial-of-service when processing certain web content (bsc#1240962) - CVE-2025-24208: permissions issue may lead to a cross-site scripting attack when loading a malicious iframe (bsc#1240961) - CVE-2025-24209: buffer overflow may lead to crash when processing maliciously crafted web content (bsc#1240964) - CVE-2025-24213: type confusion issue may lead to memory corruption (bsc#1240963) - CVE-2025-24216: improper memory handling may lead to an unexpected crash when processing certain web content (bsc#1240986) - CVE-2025-24264: improper memory handling may lead to unexpected crash when processing certain web content (bsc#1240987) - CVE-2025-30427: use-after-free issue may lead to an unexpected Safari crash when processing maliciously crafted web content (bsc#1240958)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.48.1-150600.12.36.5
Update to 2.48.1-150600.12.36.5
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.48.1-150600.12.36.5
Update to 2.48.1-150600.12.36.5
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.48.1-150600.12.36.5
Update to 2.48.1-150600.12.36.5
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.48.1-150600.12.36.5
Update to 2.48.1-150600.12.36.5
webkit2gtk3 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.48.1-150600.12.36.5
Update to 2.48.1-150600.12.36.5
webkit2gtk3-soup2 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.48.1-150600.12.36.5
Update to 2.48.1-150600.12.36.5
webkit2gtk4 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.48.1-150600.12.36.5
Update to 2.48.1-150600.12.36.5
Original sources
- https://www.suse.com/support/update/announcement/2025/suse-su-20251331-1/
- https://bugzilla.suse.com/1240958
- https://bugzilla.suse.com/1240961
- https://bugzilla.suse.com/1240962
- https://bugzilla.suse.com/1240963
- https://bugzilla.suse.com/1240964
- https://bugzilla.suse.com/1240986
- https://bugzilla.suse.com/1240987
- https://www.suse.com/security/cve/CVE-2024-54551
- https://www.suse.com/security/cve/CVE-2025-24208
- https://www.suse.com/security/cve/CVE-2025-24209
- https://www.suse.com/security/cve/CVE-2025-24213
- https://www.suse.com/security/cve/CVE-2025-24216
- https://www.suse.com/security/cve/CVE-2025-24264
- https://www.suse.com/security/cve/CVE-2025-30427
- https://osv.dev/vulnerability/SUSE-SU-2025:1331-1