SUSE-SU-2025:1345-1
SUSE-SU-2025:1345-1 · Security update for containerd
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for containerd fixes the following issues: - CVE-2024-40635: Fixed integer overflow in User ID handling (bsc#1239749) Other fixes: - Update to containerd v1.7.27.
Fix available
- Published
- Updated
Stack: system · containers
Affected products and versions
containerd SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 1.7.27-150000.123.1
Update to 1.7.27-150000.123.1
containerd SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 1.7.27-150000.123.1
Update to 1.7.27-150000.123.1
containerd SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 1.7.27-150000.123.1
Update to 1.7.27-150000.123.1
containerd SUSE:Linux Enterprise Module for Containers 15 SP6
- Affected ranges
- ECOSYSTEM: < 1.7.27-150000.123.1
Update to 1.7.27-150000.123.1
containerd SUSE:Linux Enterprise Micro 5.1
- Affected ranges
- ECOSYSTEM: < 1.7.27-150000.123.1
Update to 1.7.27-150000.123.1
containerd SUSE:Linux Enterprise Micro 5.2
- Affected ranges
- ECOSYSTEM: < 1.7.27-150000.123.1
Update to 1.7.27-150000.123.1
containerd openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 1.7.27-150000.123.1
Update to 1.7.27-150000.123.1