SUSE-SU-2025:3701-1
SUSE-SU-2025:3701-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: - CVE-2025-43343: improved memory handling in web content processing to prevent process crash (bsc#1251975) - CVE-2025-43272: improved memory handling to prevent unexpected process crash (bsc#1250439) - CVE-2025-43342: correctness issue was addressed with improved checks to prevent unexcepted process crash (bsc#1250440) - CVE-2025-43356: improved handling of caches to prevent sensor access without consent (bsc#1250441) - CVE-2025-43368: improved memory management to prevent a use-after-free (bsc#1250442)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP7
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP7
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk3 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk3-soup2 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
webkit2gtk4 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.50.1-150600.12.48.3
Update to 2.50.1-150600.12.48.3
Original sources
- https://www.suse.com/support/update/announcement/2025/suse-su-20253701-1/
- https://bugzilla.suse.com/1250439
- https://bugzilla.suse.com/1250440
- https://bugzilla.suse.com/1250441
- https://bugzilla.suse.com/1250442
- https://bugzilla.suse.com/1251975
- https://www.suse.com/security/cve/CVE-2025-43272
- https://www.suse.com/security/cve/CVE-2025-43342
- https://www.suse.com/security/cve/CVE-2025-43343
- https://www.suse.com/security/cve/CVE-2025-43356
- https://www.suse.com/security/cve/CVE-2025-43368
- https://osv.dev/vulnerability/SUSE-SU-2025:3701-1