SUSE-SU-2026:0258-1
SUSE-SU-2026:0258-1 · Security update for libsoup2
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for libsoup2 fixes the following issues: - CVE-2025-14523: Reject duplicated Host in headers and followed upstream update (bsc#1254876). - CVE-2026-0719: Fixed overflow for password md4sum (bsc#1256399)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libsoup2 SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1
libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.19.1
Update to 2.74.2-150400.3.19.1