SUSE-SU-2026:0458-1
SUSE-SU-2026:0458-1 · Security update for glib2
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for glib2 fixes the following issues: - CVE-2026-1485: Fixed buffer underflow and out-of-bounds access due to integer wraparound in content type parsing (bsc#1257354). - CVE-2026-1484: Fixed buffer underflow and out-of-bounds access due to miscalculated buffer boundaries in the Base64 encoding routine (bsc#1257355). - CVE-2026-1489: Fixed undersized heap allocation followed by out-of-bounds access due to integer overflow in Unicode case conversion (bsc#1257353). - CVE-2026-0988: Fixed a potential integer overflow in g_buffered_input_stream_peek (bsc#1257049).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
glib2 SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1
glib2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.70.5-150400.3.34.1
Update to 2.70.5-150400.3.34.1