SUSE-SU-2026:0497-1
SUSE-SU-2026:0497-1 · Security update for libsoup2
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for libsoup2 fixes the following issues: - CVE-2026-1761: Check length of bytes read in soup_filter_input_stream_read_until to avoid a stack-based buffer overflow (bsc#1257598). - CVE-2026-0716: improper bounds handling may allow out-of-bounds read (bsc#1256418). - CVE-2025-4476: null pointer dereference may lead to denial of service (bsc#1243422).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libsoup2 SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.74.2-150400.3.26.1
Update to 2.74.2-150400.3.26.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-20260497-1/
- https://bugzilla.suse.com/1243422
- https://bugzilla.suse.com/1256418
- https://bugzilla.suse.com/1257598
- https://www.suse.com/security/cve/CVE-2025-4476
- https://www.suse.com/security/cve/CVE-2026-0716
- https://www.suse.com/security/cve/CVE-2026-1761
- https://osv.dev/vulnerability/SUSE-SU-2026:0497-1