SUSE-SU-2026:0596-1
SUSE-SU-2026:0596-1 · Security update for libpng16
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for libpng16 fixes the following issues: - CVE-2025-28162: memory leaks when running `pngimage` (bsc#1257364). - CVE-2025-28164: memory leaks when running `pngimage` (bsc#1257365). - CVE-2026-22695: heap buffer over-read in png_image_finish_read (bsc#1256525). - CVE-2026-22801: integer truncation causing heap buffer over-read in png_image_write_* (bsc#1256526). - CVE-2026-25646: heap buffer overflow vulnerability in png_set_dither/png_set_quantize (bsc#1258020).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libpng16 SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
libpng16 SUSE:Linux Enterprise Micro 5.2
- Affected ranges
- ECOSYSTEM: < 1.6.34-150000.3.19.1
Update to 1.6.34-150000.3.19.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-20260596-1/
- https://bugzilla.suse.com/1256525
- https://bugzilla.suse.com/1256526
- https://bugzilla.suse.com/1257364
- https://bugzilla.suse.com/1257365
- https://bugzilla.suse.com/1258020
- https://www.suse.com/security/cve/CVE-2025-28162
- https://www.suse.com/security/cve/CVE-2025-28164
- https://www.suse.com/security/cve/CVE-2026-22695
- https://www.suse.com/security/cve/CVE-2026-22801
- https://www.suse.com/security/cve/CVE-2026-25646
- https://osv.dev/vulnerability/SUSE-SU-2026:0596-1