SUSE-SU-2026:0597-1
SUSE-SU-2026:0597-1 · Security update for libpng16
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for libpng16 fixes the following issues: - CVE-2026-25646: heap buffer overflow vulnerability in png_set_dither/png_set_quantize (bsc#1258020).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libpng16 SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Affected ranges
- ECOSYSTEM: < 1.6.40-150600.3.12.1
Update to 1.6.40-150600.3.12.1
libpng16 SUSE:Linux Enterprise Server 15 SP6-LTSS
- Affected ranges
- ECOSYSTEM: < 1.6.40-150600.3.12.1
Update to 1.6.40-150600.3.12.1
libpng16 SUSE:Linux Enterprise Server for SAP Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 1.6.40-150600.3.12.1
Update to 1.6.40-150600.3.12.1
libpng16 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 1.6.40-150600.3.12.1
Update to 1.6.40-150600.3.12.1