SUSE-SU-2026:0811-1
SUSE-SU-2026:0811-1 · Security update for libsoup2
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for libsoup2 fixes the following issues: - CVE-2026-1467: lack of input sanitization can lead to unintended or unauthorized HTTP requests (bsc#1257398). - CVE-2026-1539: proxy authentication credentials leaked via the Proxy-Authorization header when handling HTTP redirects (bsc#1257441). - CVE-2026-1760: improper handling of HTTP requests combining certain headers by SoupServer can lead to HTTP request smuggling and potential DoS (bsc#1257597).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libsoup2 SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Affected ranges
- ECOSYSTEM: < 2.74.3-150600.4.30.1
Update to 2.74.3-150600.4.30.1
libsoup2 SUSE:Linux Enterprise Server 15 SP6-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.3-150600.4.30.1
Update to 2.74.3-150600.4.30.1
libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 2.74.3-150600.4.30.1
Update to 2.74.3-150600.4.30.1
libsoup2 openSUSE:Leap 15.6
- Affected ranges
- ECOSYSTEM: < 2.74.3-150600.4.30.1
Update to 2.74.3-150600.4.30.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-20260811-1/
- https://bugzilla.suse.com/1257398
- https://bugzilla.suse.com/1257441
- https://bugzilla.suse.com/1257597
- https://www.suse.com/security/cve/CVE-2026-1467
- https://www.suse.com/security/cve/CVE-2026-1539
- https://www.suse.com/security/cve/CVE-2026-1760
- https://osv.dev/vulnerability/SUSE-SU-2026:0811-1