p PatchFirst

SUSE-SU-2026:0834-1

SUSE-SU-2026:0834-1 · Security update for libsoup2

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This update for libsoup2 fixes the following issues: - CVE-2025-32049: denial of service attack to websocket server (bsc#1240751). - CVE-2026-1467: lack of input sanitization can lead to unintended or unauthorized HTTP requests (bsc#1257398). - CVE-2026-1539: proxy authentication credentials leaked via the Proxy-Authorization header when handling HTTP redirects (bsc#1257441). - CVE-2026-1760: improper handling of HTTP requests combining certain headers by SoupServer can lead to HTTP request smuggling and potential DoS (bsc#1257597). - CVE-2026-2369: buffer overread due to integer underflow when handling zero-length resources (bsc#1258120). - CVE-2026-2443: out-of-bounds read when processing specially crafted HTTP Range headers can lead to heap information disclosure to remote attackers (bsc#1258170). - CVE-2026-2708: HTTP request smuggling via duplicate Content-Length headers (bsc#1258508).

Fix available

Published
Updated

Stack: system

Affected products and versions

  • libsoup2 SUSE:Linux Enterprise Micro 5.3

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise Micro 5.4

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise Micro 5.5

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise Server 15 SP5-LTSS

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

  • libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5

    Affected ranges
    • ECOSYSTEM: < 2.74.2-150400.3.31.1

    Update to 2.74.2-150400.3.31.1

Original sources

Check your server →