SUSE-SU-2026:1158-1
SUSE-SU-2026:1158-1 · Security update for python-pyasn1
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for python-pyasn1 fixes the following issues: - CVE-2026-30922: Denial of Service via Unbounded Recursion (bsc#1259803).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
python-pyasn1 SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Server 15 SP6-LTSS
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Server for SAP Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1
python-pyasn1 SUSE:Linux Enterprise Micro 5.2
- Affected ranges
- ECOSYSTEM: < 0.4.2-150000.3.16.1
Update to 0.4.2-150000.3.16.1