p PatchFirst

SUSE-SU-2026:22544-1

SUSE-SU-2026:22544-1 · Security update for haproxy

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This update for haproxy fixes the following issues - Update to version 3.2.21+git0.dbe43be37 - CVE-2026-55203: integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record headers (bsc#1268557). - CVE-2026-55204: null pointer dereference vulnerability in hpack_dht_insert() within src/hpack-tbl.c (bsc#1268558).

Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • haproxy SUSE:Linux Micro 6.2

    Affected ranges
    • ECOSYSTEM: < 3.2.21+git0.dbe43be37-160000.1.1

    Update to 3.2.21+git0.dbe43be37-160000.1.1

Original sources

Check your server →