SUSE-SU-2026:23144-1
SUSE-SU-2026:23144-1 · Security update for php8
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php8 fixes the following issues - Update to version 8.4.24 - CVE-2026-7260: Stack overflow in phar with circular symlinks (bsc#1273077). - CVE-2026-9672: Upgrade libgd (bsc#1273078). - CVE-2026-17543: SQL injection in ext-pgsql via E'...' backslash breakout (bsc#1273075). - CVE-2026-17544: Out-of-bounds write in bccomp() via crafted operand and scale (bsc#1273076).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php8 SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
php8 SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
php8-embed SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
php8-fastcgi SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
php8-fpm SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
apache2-mod_php8 SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
php8 SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
php8-embed SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
php8-fastcgi SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
php8-fpm SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.24-160000.1.1
Update to 8.4.24-160000.1.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-202623144-1/
- https://bugzilla.suse.com/1273075
- https://bugzilla.suse.com/1273076
- https://bugzilla.suse.com/1273077
- https://bugzilla.suse.com/1273078
- https://www.suse.com/security/cve/CVE-2026-17543
- https://www.suse.com/security/cve/CVE-2026-17544
- https://www.suse.com/security/cve/CVE-2026-7260
- https://www.suse.com/security/cve/CVE-2026-9672
- https://osv.dev/vulnerability/SUSE-SU-2026:23144-1