SUSE-SU-2026:24158-1
SUSE-SU-2026:24158-1 · Security update for php8
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php8 fixes the following issues: - CVE-2025-1218: php: php: Denial of Service via out-of-bounds read in mysqlnd wire protocol parser (bsc#1282981). - CVE-2025-14181: Integer overflow to buffer overflow in soap HTTP parsing (bsc#1283216). - CVE-2026-6103: Archive entry injection via integer overflow in TAR parser (bsc#1282980). - CVE-2026-91765: Denial of Service via unbounded recursion in SOAP parser (bsc#1282875). - CVE-2026-91766: Credential disclosure via cross-origin HTTP redirects (bsc#1282876). - CVE-2026-91767: Information disclosure via crafted TLS server certificate (bsc#1282877). - CVE-2026-91768: Access control bypass via partial IPv6 address comparison (bsc#1282878). - CVE-2026-91769: OpenSSL stream peer verification falls back to the Common Name whenever no `subjectAltName` matches, allowing trusted certificate impersonation (bsc#1283044). - CVE-2026-92842: Information disclosure via out-of-bounds read in stream filters (bsc#1282985). - CVE-2026-93682: Out-of-bounds read via empty HTTP redirect Location header (bsc#1282986). Changes for php8: - Updated to version 8.4.26
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php8 SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
php8 SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
php8-embed SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
php8-fastcgi SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
php8-fpm SUSE:Linux Enterprise Server 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
apache2-mod_php8 SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
php8 SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
php8-embed SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
php8-fastcgi SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
php8-fpm SUSE:Linux Enterprise Server for SAP applications 16.0
- Affected ranges
- ECOSYSTEM: < 8.4.26-160000.1.1
Update to 8.4.26-160000.1.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-202624158-1/
- https://bugzilla.suse.com/1282875
- https://bugzilla.suse.com/1282876
- https://bugzilla.suse.com/1282877
- https://bugzilla.suse.com/1282878
- https://bugzilla.suse.com/1282980
- https://bugzilla.suse.com/1282981
- https://bugzilla.suse.com/1282985
- https://bugzilla.suse.com/1282986
- https://bugzilla.suse.com/1283044
- https://bugzilla.suse.com/1283216
- https://www.suse.com/security/cve/CVE-2025-1218
- https://www.suse.com/security/cve/CVE-2025-14181
- https://www.suse.com/security/cve/CVE-2026-6103
- https://www.suse.com/security/cve/CVE-2026-91765
- https://www.suse.com/security/cve/CVE-2026-91766
- https://www.suse.com/security/cve/CVE-2026-91767
- https://www.suse.com/security/cve/CVE-2026-91768
- https://www.suse.com/security/cve/CVE-2026-91769
- https://www.suse.com/security/cve/CVE-2026-92842
- https://www.suse.com/security/cve/CVE-2026-93682
- https://osv.dev/vulnerability/SUSE-SU-2026:24158-1