SUSE-SU-2026:2639-1
SUSE-SU-2026:2639-1 · Security update for containerd
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for containerd fixes the following issues - CVE-2026-33186: google.golang.org/grpc: authorization bypass due to improper validation of the HTTP/2 :path pseudo- header (bsc#1260296). - CVE-2026-33814: golang.org/x/net/http2: infinite loop in HTTP/2 transport when given bad SETTINGS_MAX_FRAME_SIZE (bsc#1265794). - CVE-2026-34986: github.com/go-jose/go-jose/v3: crafted JWE input with a missing encrypted key can lead to a denial of service (bsc#1262948). - CVE-2026-39821: golang.org/x/net/idna: failure to reject ASCII-only Punycode-encoded labels allows for validation bypass and privilege escalation (bsc#1266640).
Fix available
- Published
- Updated
Stack: system · containers
Affected products and versions
containerd SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Module for Containers 15 SP7
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Server 15 SP6-LTSS
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
containerd SUSE:Linux Enterprise Server for SAP Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 1.7.29-150000.137.1
Update to 1.7.29-150000.137.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-20262639-1/
- https://bugzilla.suse.com/1260296
- https://bugzilla.suse.com/1262948
- https://bugzilla.suse.com/1265794
- https://bugzilla.suse.com/1266640
- https://www.suse.com/security/cve/CVE-2026-33186
- https://www.suse.com/security/cve/CVE-2026-33814
- https://www.suse.com/security/cve/CVE-2026-34986
- https://www.suse.com/security/cve/CVE-2026-39821
- https://osv.dev/vulnerability/SUSE-SU-2026:2639-1