SUSE-SU-2026:2749-1
SUSE-SU-2026:2749-1 · Security update for perl-DBI
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for perl-DBI fixes the following issues - CVE-2026-9698: DBI versions before 1.648 for Perl saved errors in a limited-sized buffer (bsc#1267957). - CVE-2026-10879: SQL statements with more than 9 binders can cause an heap overflow (bsc#1267849).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
perl-dbi SUSE:Linux Enterprise Module for Basesystem 15 SP7
- Affected ranges
- ECOSYSTEM: < 1.647.0-150600.12.11.1
Update to 1.647.0-150600.12.11.1
perl-dbi SUSE:Linux Enterprise Server 15 SP6-LTSS
- Affected ranges
- ECOSYSTEM: < 1.647.0-150600.12.11.1
Update to 1.647.0-150600.12.11.1
perl-dbi SUSE:Linux Enterprise Server for SAP Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 1.647.0-150600.12.11.1
Update to 1.647.0-150600.12.11.1