SUSE-SU-2026:3510-1
SUSE-SU-2026:3510-1 · Security update for php7
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
This update for php7 fixes the following issues: - CVE-2026-7260: circular symbolic links in phar archives can lead to unbounded recursion and cause C stack exhaustion (bsc#1273077). - CVE-2026-9672: security issues in `libgd` (bsc#1273078). - CVE-2026-17543: improper escaping of backslashes in user-provided parameters allows for trivial SQL injection in `ext-pgsql` (bsc#1273075).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP7
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7 SUSE:Linux Enterprise Module for Legacy 15 SP7
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
apache2-mod_php7 SUSE:Linux Enterprise Module for Package Hub 15 SP7
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7 SUSE:Linux Enterprise Module for Package Hub 15 SP7
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP7
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fastcgi SUSE:Linux Enterprise Module for Package Hub 15 SP7
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fpm SUSE:Linux Enterprise Module for Package Hub 15 SP7
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-test SUSE:Linux Enterprise Module for Package Hub 15 SP7
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.2
Update to 7.4.33-150400.4.68.2
apache2-mod_php7 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fastcgi SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fpm SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
apache2-mod_php7 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fastcgi SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fpm SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
apache2-mod_php7 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fastcgi SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fpm SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
apache2-mod_php7 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fastcgi SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
php7-fpm SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.33-150400.4.68.1
Update to 7.4.33-150400.4.68.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-20263510-1/
- https://bugzilla.suse.com/1273075
- https://bugzilla.suse.com/1273077
- https://bugzilla.suse.com/1273078
- https://www.suse.com/security/cve/CVE-2026-17543
- https://www.suse.com/security/cve/CVE-2026-7260
- https://www.suse.com/security/cve/CVE-2026-9672
- https://osv.dev/vulnerability/SUSE-SU-2026:3510-1