SUSE-SU-2026:3936-1
SUSE-SU-2026:3936-1 · Security update for libsoup2
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for libsoup2 fixes the following issues: - CVE-2026-12548: out-of-bounds read in multipart body parser due to an integer truncation (bsc#1272196). Changes for libsoup2: - tld-test: update after changes in the public suffix list: '*.bd' is no longer in the public suffix list so let's use '.jm' instead. - Increase test timeout for all arches except x86_64 and run tests again should they fail the first time, the testsuite is flaky. - Increase test timeout on s390x. The http2-body-stream test can be slow and sometimes times out in our builds. - fix an intermittent test failure (glgo#GNOME/libsoup#399). - Fix build with libxml2-2.12.0 and clang-17. - Add upstream bug fixes: + lib: Add g_task_set_source_tag() everywhere + lib: Add names to various GSources - Drop no longer valid translation-update-upstream BuildRequires and macro. - Use ldconfig_scriptlets macro for post(un) handling. - Update to version 2.74.3: + Add missing g-i annotations to `soup_address_get_sockaddr()` and `soup_socket_read_until()`. + Add missing `extern` when building on Windows. + Update libxml2 fallback for meson wrap. + Improvements when using libsoup with meson wraps.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libsoup2 SUSE:Linux Enterprise Micro 5.3
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise Micro 5.4
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
libsoup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 2.74.3-150400.3.40.1
Update to 2.74.3-150400.3.40.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-20263936-1/
- https://bugzilla.suse.com/1241686
- https://bugzilla.suse.com/1241688
- https://bugzilla.suse.com/1254876
- https://bugzilla.suse.com/1272196
- https://www.suse.com/security/cve/CVE-2025-14523
- https://www.suse.com/security/cve/CVE-2025-46420
- https://www.suse.com/security/cve/CVE-2025-46421
- https://www.suse.com/security/cve/CVE-2026-12548
- https://osv.dev/vulnerability/SUSE-SU-2026:3936-1