SUSE-SU-2026:4175-1
SUSE-SU-2026:4175-1 · Security update for helm
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for helm fixes the following issues: - CVE-2026-37236: github.com/grpc-ecosystem/grpc-gateway/v2/runtime: client can override the HTTP method of a POST request through the X-HTTP-Method-Override header and bypass established access control (bsc#1277949). - CVE-2026-41178: go.opentelemetry.io/otel/baggage: no rejection of raw-length headers in baggage parsing allows for DoS via oversized inputs (bsc#1276644). - CVE-2026-84303: github.com/grpc/grpc-go: xDS RBAC HTTP filter implementation issue allows for bypass of authorization policies via mixed-case or canonical-case header matches (bsc#1278270). - CVE-2026-84304: github.com/grpc/grpc-go: heap memory exhaustion via HTTP/2 DATA frame fragmentation (bsc#1278273). - CVE-2026-84445: google.golang.org/grpc: DoS via crash due to missing `:authority` and `Host` headers in gRPC-Go xDS servers (bsc#1278688).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
helm SUSE:Linux Enterprise Micro 5.5
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise Module for Containers 15 SP7
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise Module for Package Hub 15 SP7
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise Server 15 SP5-LTSS
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise Server 15 SP6-LTSS
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
helm SUSE:Linux Enterprise Server for SAP Applications 15 SP6
- Affected ranges
- ECOSYSTEM: < 3.21.3-150000.1.96.1
Update to 3.21.3-150000.1.96.1
Original sources
- https://www.suse.com/support/update/announcement/2026/suse-su-20264175-1/
- https://bugzilla.suse.com/1276644
- https://bugzilla.suse.com/1277949
- https://bugzilla.suse.com/1278270
- https://bugzilla.suse.com/1278273
- https://bugzilla.suse.com/1278688
- https://www.suse.com/security/cve/CVE-2026-37236
- https://www.suse.com/security/cve/CVE-2026-41178
- https://www.suse.com/security/cve/CVE-2026-84303
- https://www.suse.com/security/cve/CVE-2026-84304
- https://www.suse.com/security/cve/CVE-2026-84445
- https://osv.dev/vulnerability/SUSE-SU-2026:4175-1