p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities · Page 2

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 28

  1. CVE-2015-3185

    Not ratedEPSS 16.35%Fix available

    CVE-2015-3185

    The ap_some_auth_required function in server/request.c in the Apache HTTP Server 2.4.x before 2.4.14 does not consider that a Require directive may be associated with an authorization setting rather than an authentication setting, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging the presence of a module that relies on the 2.2 API behavior.

    • Update to 2.4.7-1ubuntu4.5
    Published Updated
  2. CVE-2015-3183

    Not ratedEPSS 74.54%Fix available

    CVE-2015-3183

    The chunked transfer coding implementation in the Apache HTTP Server before 2.4.14 does not properly parse chunk headers, which allows remote attackers to conduct HTTP request smuggling attacks via a crafted request, related to mishandling of large chunk-size values and invalid chunk-extension characters in modules/http/http_filters.c.

    • Update to 2.4.7-1ubuntu4.5
    Published Updated
  3. CVE-2014-0226

    Not ratedEPSS 85.74%Public exploitFix available

    CVE-2014-0226

    Race condition in the mod_status module in the Apache HTTP Server before 2.4.10 allows remote attackers to cause a denial of service (heap-based buffer overflow), or possibly obtain sensitive credential information or execute arbitrary code, via a crafted request that triggers improper scoreboard handling within the status_handler function in modules/generators/mod_status.c and the lua_ap_scoreboard_worker function in modules/lua/lua_request.c.

    • Update to 2.4.7-1ubuntu4.1
    Published Updated
  4. CVE-2014-0118

    Not ratedEPSS 37.16%Fix available

    CVE-2014-0118

    The deflate_in_filter function in mod_deflate.c in the mod_deflate module in the Apache HTTP Server before 2.4.10, when request body decompression is enabled, allows remote attackers to cause a denial of service (resource consumption) via crafted request data that decompresses to a much larger size.

    • Update to 2.4.7-1ubuntu4.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →