p PatchFirst

PatchFirst · Latest vulnerabilities

libgd2 vulnerabilities · Page 2

Vulnerabilities published for libgd2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 32

  1. CVE-2016-5766

    High · CVSS 8.8EPSS 7.5%Fix available

    CVE-2016-5766

    Integer overflow in the _gd2GetHeader function in gd_gd2.c in the GD Graphics Library (aka libgd) before 2.2.3, as used in PHP before 5.5.37, 5.6.x before 5.6.23, and 7.x before 7.0.8, allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via crafted chunk dimensions in an image.

    • Update to 2.1.0-3ubuntu0.2
    Published Updated
  2. CVE-2016-5116

    Critical · CVSS 9.1EPSS 3.81%Fix available

    CVE-2016-5116

    gd_xbm.c in the GD Graphics Library (aka libgd) before 2.2.0, as used in certain custom PHP 5.5.x configurations, allows context-dependent attackers to obtain sensitive information from process memory or cause a denial of service (stack-based buffer under-read and application crash) via a long name.

    • Update to 2.1.0-3ubuntu0.2
    Published Updated
  3. CVE-2013-7456

    High · CVSS 7.6EPSS 3.83%Fix available

    CVE-2013-7456

    gd_interpolation.c in the GD Graphics Library (aka libgd) before 2.1.1, as used in PHP before 5.5.36, 5.6.x before 5.6.22, and 7.x before 7.0.7, allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a crafted image that is mishandled by the imagescale function.

    • Update to 2.1.0-3ubuntu0.2
    Published Updated
  4. CVE-2015-8877

    High · CVSS 7.5EPSS 3.65%Fix available

    CVE-2015-8877

    The gdImageScaleTwoPass function in gd_interpolation.c in the GD Graphics Library (aka libgd) before 2.2.0, as used in PHP before 5.6.12, uses inconsistent allocate and free approaches, which allows remote attackers to cause a denial of service (memory consumption) via a crafted call, as demonstrated by a call to the PHP imagescale function.

    • Update to 2.1.0-3ubuntu0.1
    Published Updated
  5. CVE-2014-9709

    Not ratedEPSS 15.43%Fix available

    CVE-2014-9709

    The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.

    • Update to 2.1.0-3ubuntu0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →