p PatchFirst

PatchFirst · Latest vulnerabilities

linux-lts-xenial vulnerabilities · Page 2

Vulnerabilities published for linux-lts-xenial in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 426

  1. CVE-2019-11091

    Medium · CVSS 5.6EPSS 0.61%Fix available

    CVE-2019-11091

    Microarchitectural Data Sampling Uncacheable Memory (MDSUM): Uncacheable memory on some microprocessors utilizing speculative execution may allow an authenticated user to potentially enable information disclosure via a side channel with local access. A list of impacted products can be found here: https://www.intel.com/content/dam/www/public/us/en/documents/corporate-information/SA00233-microcode-update-guidance_05132019.pdf

    • Update to 4.4.0-148.174~14.04.1
    Published Updated
  2. CVE-2019-3882

    Medium · CVSS 4.7EPSS 0.54%Fix available

    CVE-2019-3882

    A flaw was found in the Linux kernel's vfio interface implementation that permits violation of the user's locked memory limit. If a device is bound to a vfio driver, such as vfio-pci, and the local attacker is administratively granted ownership of the device, it may cause a system memory exhaustion and thus a denial of service (DoS). Versions 3.10, 4.14 and 4.18 are vulnerable.

    • Update to 4.4.0-148.174~14.04.1
    Published Updated
  3. CVE-2019-3901

    Medium · CVSS 5.6EPSS 0.34%Fix available

    CVE-2019-3901

    A race condition in perf_event_open() allows local attackers to leak sensitive data from setuid programs. As no relevant locks (in particular the cred_guard_mutex) are held during the ptrace_may_access() call, it is possible for the specified target task to perform an execve() syscall with setuid execution before perf_event_alloc() actually attaches to it, allowing an attacker to bypass the ptrace_may_access() check and the perf_event_exit_task(current) call that is performed in install_exec_creds() during privileged execve() calls. This issue affects kernel versions before 4.8.

    • Update to 4.4.0-28.47~14.04.1
    Published Updated
  4. CVE-2018-19985

    Medium · CVSS 4.6EPSS 0.95%Fix available

    CVE-2018-19985

    The function hso_get_config_data in drivers/net/usb/hso.c in the Linux kernel through 4.19.8 reads if_num from the USB device (as a u8) and uses it to index a small array, resulting in an object out-of-bounds (OOB) read that potentially allows arbitrary read in the kernel address space.

    • Update to 4.4.0-143.169~14.04.2
    Published Updated
  5. CVE-2019-9213

    Medium · CVSS 5.5EPSS 5.67%Public exploitFix available

    CVE-2019-9213

    In the Linux kernel before 4.20.14, expand_downwards in mm/mmap.c lacks a check for the mmap minimum address, which makes it easier for attackers to exploit kernel NULL pointer dereferences on non-SMAP platforms. This is related to a capability check for the wrong task.

    • Update to 4.4.0-144.170~14.04.1
    Published Updated
  6. CVE-2019-2001

    Medium · CVSS 5.5EPSS 0.18%Fix available

    CVE-2019-2001

    The permissions on /proc/iomem were world-readable. This could lead to local information disclosure with no additional execution privileges needed. User interaction is not needed for exploitation. Product: Android. Versions: Android kernel. Android ID: A-117422211.

    • Update to 4.4.0-87.110~14.04.1
    Published Updated
  7. CVE-2016-10741

    Medium · CVSS 4.7EPSS 0.32%Fix available

    CVE-2016-10741

    In the Linux kernel before 4.9.3, fs/xfs/xfs_aops.c allows local users to cause a denial of service (system crash) because there is a race condition between direct and memory-mapped I/O (associated with a hole) that is handled with BUG_ON instead of an I/O failure.

    • Update to 4.4.0-96.119~14.04.1
    Published Updated
  8. CVE-2019-3819

    Medium · CVSS 4.2EPSS 0.46%Fix available

    CVE-2019-3819

    A flaw was found in the Linux kernel in the function hid_debug_events_read() in drivers/hid/hid-debug.c file which may enter an infinite loop with certain parameters passed from a userspace. A local privileged user ("root") can cause a system lock up and a denial of service. Versions from v4.18 and newer are vulnerable.

    • Update to 4.4.0-144.170~14.04.1
    Published Updated
  9. CVE-2019-6133

    Medium · CVSS 6.7EPSS 0.45%Fix available

    CVE-2019-6133

    In PolicyKit (aka polkit) 0.115, the "start time" protection mechanism can be bypassed because fork() is not atomic, and therefore authorization decisions are improperly cached. This is related to lack of uid checking in polkitbackend/polkitbackendinteractiveauthority.c.

    • Update to 4.4.0-143.169~14.04.2
    Published Updated
  10. CVE-2019-3701

    Medium · CVSS 4.4EPSS 0.7%Fix available

    CVE-2019-3701

    An issue was discovered in can_can_gw_rcv in net/can/gw.c in the Linux kernel through 4.19.13. The CAN frame modification rules allow bitwise logical operations that can be also applied to the can_dlc field. The privileged user "root" with CAP_NET_ADMIN can create a CAN frame modification rule that makes the data length code a higher value than the available CAN frame data size. In combination with a configured checksum calculation where the result is stored relatively to the end of the data (e.g. cgw_csum_xor_rel) the tail of the skb (e.g. frag_list pointer in skb_shared_info) can be rewritten which finally can cause a system crash. Because

    • Update to 4.4.0-144.170~14.04.1
    Published Updated
  11. CVE-2018-20511

    Medium · CVSS 5.5EPSS 0.47%Fix available

    CVE-2018-20511

    An issue was discovered in the Linux kernel before 4.18.11. The ipddp_ioctl function in drivers/net/appletalk/ipddp.c allows local users to obtain sensitive kernel address information by leveraging CAP_NET_ADMIN to read the ipddp_route dev and next fields via an SIOCFINDIPDDPRT ioctl call.

    • Update to 4.4.0-139.165~14.04.1
    Published Updated
  12. CVE-2018-16884

    Medium · CVSS 6.5EPSS 1.46%Fix available

    CVE-2018-16884

    A flaw was found in the Linux kernel's NFS41+ subsystem. NFS41+ shares mounted in different network namespaces at the same time can make bc_svc_process() use wrong back-channel IDs and cause a use-after-free vulnerability. Thus a malicious container user can cause a host kernel memory corruption and a system panic. Due to the nature of the flaw, privilege escalation cannot be fully ruled out.

    • Update to 4.4.0-144.170~14.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →