p PatchFirst

PatchFirst · Latest vulnerabilities

linux vulnerabilities · Page 13

Vulnerabilities published for linux in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 514

  1. CVE-2016-8655

    High · CVSS 7.8EPSS 11.13%Public exploitFix available

    CVE-2016-8655

    Race condition in net/packet/af_packet.c in the Linux kernel through 4.8.12 allows local users to gain privileges or cause a denial of service (use-after-free) by leveraging the CAP_NET_RAW capability to change a socket version, related to the packet_set_ring and packet_setsockopt functions.

    • Update to 3.13.0-105.152
    Published Updated
  2. CVE-2016-9644

    High · CVSS 7.8EPSS 1.45%Fix available

    CVE-2016-9644

    The __get_user_asm_ex macro in arch/x86/include/asm/uaccess.h in the Linux kernel 4.4.22 through 4.4.28 contains extended asm statements that are incompatible with the exception table, which allows local users to obtain root access on non-SMEP platforms via a crafted application. NOTE: this vulnerability exists because of incorrect backporting of the CVE-2016-9178 patch to older kernels.

    • Update to 3.13.0-145.194
    Published Updated
  3. CVE-2016-9555

    Critical · CVSS 9.8EPSS 10.02%Fix available

    CVE-2016-9555

    The sctp_sf_ootb function in net/sctp/sm_statefuns.c in the Linux kernel before 4.8.8 lacks chunk-length checking for the first chunk, which allows remote attackers to cause a denial of service (out-of-bounds slab access) or possibly have unspecified other impact via crafted SCTP data.

    • Update to 3.13.0-108.155
    Published Updated
  4. CVE-2016-9191

    Medium · CVSS 5.5EPSS 0.42%Fix available

    CVE-2016-9191

    The cgroup offline implementation in the Linux kernel through 4.8.11 mishandles certain drain operations, which allows local users to cause a denial of service (system hang) by leveraging access to a container environment for executing a crafted application, as demonstrated by trinity.

    • Update to 3.13.0-132.181
    Published Updated
  5. CVE-2016-9178

    Medium · CVSS 5.5EPSS 0.43%Fix available

    CVE-2016-9178

    The __get_user_asm_ex macro in arch/x86/include/asm/uaccess.h in the Linux kernel before 4.7.5 does not initialize a certain integer variable, which allows local users to obtain sensitive information from kernel stack memory by triggering failure of a get_user_ex call.

    • Update to 3.13.0-132.181
    Published Updated
  6. CVE-2016-9083

    High · CVSS 7.8EPSS 0.38%Fix available

    CVE-2016-9083

    drivers/vfio/pci/vfio_pci.c in the Linux kernel through 4.8.11 allows local users to bypass integer overflow checks, and cause a denial of service (memory corruption) or have unspecified other impact, by leveraging access to a vfio PCI device file for a VFIO_DEVICE_SET_IRQS ioctl call, aka a "state machine confusion bug."

    • Update to 3.13.0-132.181
    Published Updated
  7. CVE-2016-8650

    Medium · CVSS 5.5EPSS 0.41%Fix available

    CVE-2016-8650

    The mpi_powm function in lib/mpi/mpi-pow.c in the Linux kernel through 4.8.11 does not ensure that memory is allocated for limb data, which allows local users to cause a denial of service (stack memory corruption and panic) via an add_key system call for an RSA key with a zero exponent.

    • Update to 3.13.0-132.181
    Published Updated
  8. CVE-2016-8632

    High · CVSS 7.8EPSS 0.4%Fix available

    CVE-2016-8632

    The tipc_msg_build function in net/tipc/msg.c in the Linux kernel through 4.8.11 does not validate the relationship between the minimum fragment length and the maximum packet size, which allows local users to gain privileges or cause a denial of service (heap-based buffer overflow) by leveraging the CAP_NET_ADMIN capability.

    • Update to 3.13.0-135.184
    Published Updated
  9. CVE-2015-1328

    High · CVSS 7.8EPSS 37.68%Public exploitFix available

    CVE-2015-1328

    The overlayfs implementation in the linux (aka Linux kernel) package before 3.19.0-21.21 in Ubuntu through 15.04 does not properly check permissions for file creation in the upper filesystem directory, which allows local users to obtain root access by leveraging a configuration in which overlayfs is permitted in an arbitrary mount namespace.

    • Update to 3.13.0-55.92
    Published Updated
  10. CVE-2016-7916

    Medium · CVSS 5.5EPSS 0.39%Fix available

    CVE-2016-7916

    Race condition in the environ_read function in fs/proc/base.c in the Linux kernel before 4.5.4 allows local users to obtain sensitive information from kernel memory by reading a /proc/*/environ file during a process-setup time interval in which environment-variable copying is incomplete.

    • Update to 3.13.0-106.153
    Published Updated
  11. CVE-2016-7915

    Medium · CVSS 5.5EPSS 1.9%Fix available

    CVE-2016-7915

    The hid_input_field function in drivers/hid/hid-core.c in the Linux kernel before 4.6 allows physically proximate attackers to obtain sensitive information from kernel memory or cause a denial of service (out-of-bounds read) by connecting a device, as demonstrated by a Logitech DJ receiver.

    • Update to 3.13.0-92.139
    Published Updated
  12. CVE-2016-7914

    Medium · CVSS 5.5EPSS 2.03%Fix available

    CVE-2016-7914

    The assoc_array_insert_into_terminal_node function in lib/assoc_array.c in the Linux kernel before 4.5.3 does not check whether a slot is a leaf, which allows local users to obtain sensitive information from kernel memory or cause a denial of service (invalid pointer dereference and out-of-bounds read) via an application that uses associative-array data structures, as demonstrated by the keyutils test suite.

    • Update to 3.13.0-129.178
    Published Updated
  13. CVE-2016-7913

    High · CVSS 7.8EPSS 2.16%Fix available

    CVE-2016-7913

    The xc2028_set_config function in drivers/media/tuners/tuner-xc2028.c in the Linux kernel before 4.6 allows local users to gain privileges or cause a denial of service (use-after-free) via vectors involving omission of the firmware name from a certain data structure.

    • Update to 3.13.0-161.211
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →