p PatchFirst

PatchFirst · Latest vulnerabilities

linux vulnerabilities · Page 2

Vulnerabilities published for linux in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 514

  1. CVE-2018-18710

    Medium · CVSS 5.5EPSS 0.5%Fix available

    CVE-2018-18710

    An issue was discovered in the Linux kernel through 4.19. An information leak in cdrom_ioctl_select_disc in drivers/cdrom/cdrom.c could be used by local attackers to read kernel memory because a cast from unsigned long to int interferes with bounds checking. This is similar to CVE-2018-10940 and CVE-2018-16658.

    • Update to 3.13.0-164.214
    Published Updated
  2. CVE-2018-18690

    Medium · CVSS 5.5EPSS 0.68%Fix available

    CVE-2018-18690

    In the Linux kernel before 4.17, a local attacker able to set attributes on an xfs filesystem could make this filesystem non-operational until the next mount by triggering an unchecked error condition during an xfs attribute change, because xfs_attr_shortform_addname in fs/xfs/libxfs/xfs_attr.c mishandles ATTR_REPLACE operations with conversion of an attr from short to long form.

    • Update to 3.13.0-164.214
    Published Updated
  3. CVE-2018-17972

    Medium · CVSS 5.5EPSS 0.36%Fix available

    CVE-2018-17972

    An issue was discovered in the proc_pid_stack function in fs/proc/base.c in the Linux kernel through 4.18.11. It does not ensure that only root may inspect the kernel stack of an arbitrary task, allowing a local attacker to exploit racy stack unwinding and leak kernel task stack contents.

    • Update to 3.13.0-165.215
    Published Updated
  4. CVE-2018-14634

    High · CVSS 7.8EPSS 14.69%In KEVPublic exploitFix available

    CVE-2018-14634

    An integer overflow flaw was found in the Linux kernel's create_elf_tables() function. An unprivileged local user with access to SUID (or otherwise privileged) binary could use this flaw to escalate their privileges on the system. Kernel versions 2.6.x, 3.10.x and 4.14.x are believed to be vulnerable.

    • Update to 3.13.0-160.210
    Published Updated
  5. CVE-2018-14633

    High · CVSS 7EPSS 8.74%Fix available

    CVE-2018-14633

    A security flaw was found in the chap_server_compute_md5() function in the ISCSI target code in the Linux kernel in a way an authentication request from an ISCSI initiator is processed. An unauthenticated remote attacker can cause a stack buffer overflow and smash up to 17 bytes of the stack. The attack requires the iSCSI target to be enabled on the victim host. Depending on how the target's code was built (i.e. depending on a compiler, compile flags and hardware architecture) an attack may lead to a system crash and thus to a denial-of-service or possibly to a non-authorized access to data exported by an iSCSI target. Due to the nature of th

    • Update to 3.13.0-160.210
    Published Updated
  6. CVE-2018-16658

    Medium · CVSS 6.1EPSS 0.55%Fix available

    CVE-2018-16658

    An issue was discovered in the Linux kernel before 4.18.6. An information leak in cdrom_ioctl_drive_status in drivers/cdrom/cdrom.c could be used by local attackers to read kernel memory because a cast from unsigned long to int interferes with bounds checking. This is similar to CVE-2018-10940.

    • Update to 3.13.0-162.212
    Published Updated
  7. CVE-2018-5391

    High · CVSS 7.5EPSS 32.45%Fix available

    The Linux kernel, versions 3.9+, IP implementation is vulnerable to denial of service conditions with low rates of specially modified packets

    The Linux kernel, versions 3.9+, is vulnerable to a denial of service attack with low rates of specially modified packets targeting IP fragment re-assembly. An attacker may cause a denial of service condition by sending specially crafted IP fragments. Various vulnerabilities in IP fragmentation have been discovered and fixed over the years. The current vulnerability (CVE-2018-5391) became exploitable in the Linux kernel with the increase of the IP fragment reassembly queue size.

    • Update to 3.13.0-155.205
    Published Updated
  8. CVE-2018-6555

    High · CVSS 7.8EPSS 0.5%Fix available

    CVE-2018-6555

    The irda_setsockopt function in net/irda/af_irda.c and later in drivers/staging/irda/net/af_irda.c in the Linux kernel before 4.17 allows local users to cause a denial of service (ias_object use-after-free and system crash) or possibly have unspecified other impact via an AF_IRDA socket.

    • Update to 3.13.0-160.210
    Published Updated
  9. CVE-2018-10902

    High · CVSS 7.8EPSS 0.52%Fix available

    CVE-2018-10902

    It was found that the raw midi kernel driver does not protect against concurrent access which leads to a double realloc (double free) in snd_rawmidi_input_params() and snd_rawmidi_output_status() which are part of snd_rawmidi_ioctl() handler in rawmidi.c file. A malicious local attacker could possibly use this for privilege escalation.

    • Update to 3.13.0-164.214
    Published Updated
  10. USN-3741-3

    Not ratedFix available

    linux regressions

    USN-3741-1 introduced mitigations in the Linux kernel for Ubuntu 14.04 LTS to address L1 Terminal Fault (L1TF) vulnerabilities (CVE-2018-3620, CVE-2018-3646). Unfortunately, the update introduced regressions that caused kernel panics when booting in some environments as well as preventing Java applications from starting. This update fixes the problems. We apologize for the inconvenience. Original advisory details: It was discovered that memory present in the L1 data cache of an Intel CPU core may be exposed to a malicious process that is executing on the CPU core. This vulnerability is also known as L1 Terminal Fault (L1TF). A local at

    • Update to 3.13.0-156.206
    Published Updated
  11. CVE-2018-3646

    Medium · CVSS 5.6EPSS 8.1%Fix available

    CVE-2018-3646

    Systems with microprocessors utilizing speculative execution and address translations may allow unauthorized disclosure of information residing in the L1 data cache to an attacker with local user access with guest OS privilege via a terminal page fault and a side-channel analysis.

    • Update to 3.13.0-155.205
    Published Updated
  12. CVE-2018-5390

    High · CVSS 7.5EPSS 71.77%Fix available

    Linux kernel versions 4.9+ can be forced to make very expensive calls to tcp_collapse_ofo_queue() and tcp_prune_ofo_queue() for every incoming packet which can lead to a denial of service

    Linux kernel versions 4.9+ can be forced to make very expensive calls to tcp_collapse_ofo_queue() and tcp_prune_ofo_queue() for every incoming packet which can lead to a denial of service.

    • Update to 3.13.0-155.205
    Published Updated
  13. CVE-2017-7482

    High · CVSS 7.1EPSS 0.47%Fix available

    CVE-2017-7482

    In the Linux kernel before version 4.12, Kerberos 5 tickets decoded when using the RXRPC keys incorrectly assumes the size of a field. This could lead to the size-remaining variable wrapping and the data pointer going over the end of the buffer. This could possibly lead to memory corruption and possible privilege escalation.

    • Update to 3.13.0-126.175
    Published Updated
  14. CVE-2017-7518

    Medium · CVSS 5.5EPSS 0.67%Fix available

    CVE-2017-7518

    A flaw was found in the Linux kernel before version 4.12 in the way the KVM module processed the trap flag(TF) bit in EFLAGS during emulation of the syscall instruction, which leads to a debug exception(#DB) being raised in the guest stack. A user/process inside a guest could use this flaw to potentially escalate their privileges inside the guest. Linux guests are not affected by this.

    • Update to 3.13.0-157.207
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →