p PatchFirst

PatchFirst · Latest vulnerabilities

php5 vulnerabilities · Page 9

Vulnerabilities published for php5 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 177

  1. CVE-2014-3668

    Not ratedEPSS 27.02%Fix available

    CVE-2014-3668

    Buffer overflow in the date_from_ISO8601 function in the mkgmtime implementation in libxmlrpc/xmlrpc.c in the XMLRPC extension in PHP before 5.4.34, 5.5.x before 5.5.18, and 5.6.x before 5.6.2 allows remote attackers to cause a denial of service (application crash) via (1) a crafted first argument to the xmlrpc_set_type function or (2) a crafted argument to the xmlrpc_decode function, related to an out-of-bounds read operation.

    • Update to 5.5.9+dfsg-1ubuntu4.5
    Published Updated
  2. CVE-2014-3597

    Not ratedEPSS 15.43%Fix available

    CVE-2014-3597

    Multiple buffer overflows in the php_parserr function in ext/standard/dns.c in PHP before 5.4.32 and 5.5.x before 5.5.16 allow remote DNS servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted DNS record, related to the dns_get_record function and the dn_expand function. NOTE: this issue exists because of an incomplete fix for CVE-2014-4049.

    • Update to 5.5.9+dfsg-1ubuntu4.4
    Published Updated
  3. CVE-2014-3587

    Not ratedEPSS 20.24%Fix available

    CVE-2014-3587

    Integer overflow in the cdf_read_property_info function in cdf.c in file through 5.19, as used in the Fileinfo component in PHP before 5.4.32 and 5.5.x before 5.5.16, allows remote attackers to cause a denial of service (application crash) via a crafted CDF file. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-1571.

    • Update to 5.5.9+dfsg-1ubuntu4.4
    Published Updated
  4. CVE-2014-4698

    Not ratedEPSS 0.68%Fix available

    CVE-2014-4698

    Use-after-free vulnerability in ext/spl/spl_array.c in the SPL component in PHP through 5.5.14 allows context-dependent attackers to cause a denial of service or possibly have unspecified other impact via crafted ArrayIterator usage within applications in certain web-hosting environments.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  5. CVE-2014-4670

    Not ratedEPSS 0.71%Fix available

    CVE-2014-4670

    Use-after-free vulnerability in ext/spl/spl_dllist.c in the SPL component in PHP through 5.5.14 allows context-dependent attackers to cause a denial of service or possibly have unspecified other impact via crafted iterator usage within applications in certain web-hosting environments.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  6. CVE-2014-3515

    Not ratedEPSS 30.13%Fix available

    CVE-2014-3515

    The SPL component in PHP before 5.4.30 and 5.5.x before 5.5.14 incorrectly anticipates that certain data structures will have the array data type after unserialization, which allows remote attackers to execute arbitrary code via a crafted string that triggers use of a Hashtable destructor, related to "type confusion" issues in (1) ArrayObject and (2) SPLObjectStorage.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  7. CVE-2014-3487

    Not ratedEPSS 14.93%Fix available

    CVE-2014-3487

    The cdf_read_property_info function in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, does not properly validate a stream offset, which allows remote attackers to cause a denial of service (application crash) via a crafted CDF file.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  8. CVE-2014-3480

    Medium · CVSS 6.5EPSS 11.48%Fix available

    CVE-2014-3480

    The cdf_count_chain function in cdf.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, does not properly validate sector-count data, which allows remote attackers to cause a denial of service (application crash) via a crafted CDF file.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  9. CVE-2014-3479

    Not ratedEPSS 14.93%Fix available

    CVE-2014-3479

    The cdf_check_stream_offset function in cdf.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, relies on incorrect sector-size data, which allows remote attackers to cause a denial of service (application crash) via a crafted stream offset in a CDF file.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  10. CVE-2014-3478

    Medium · CVSS 6.5EPSS 15.18%Fix available

    CVE-2014-3478

    Buffer overflow in the mconvert function in softmagic.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, allows remote attackers to cause a denial of service (application crash) via a crafted Pascal string in a FILE_PSTRING conversion.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  11. CVE-2014-0207

    Medium · CVSS 6.5EPSS 16.93%Fix available

    CVE-2014-0207

    The cdf_read_short_sector function in cdf.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, allows remote attackers to cause a denial of service (assertion failure and application exit) via a crafted CDF file.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  12. CVE-2014-4721

    Not ratedEPSS 5.87%Fix available

    CVE-2014-4721

    The phpinfo implementation in ext/standard/info.c in PHP before 5.4.30 and 5.5.x before 5.5.14 does not ensure use of the string data type for the PHP_AUTH_PW, PHP_AUTH_TYPE, PHP_AUTH_USER, and PHP_SELF variables, which might allow context-dependent attackers to obtain sensitive information from process memory by using the integer data type with crafted values, related to a "type confusion" vulnerability, as demonstrated by reading a private SSL key in an Apache HTTP Server web-hosting environment with mod_ssl and a PHP 5.3.x mod_php.

    • Update to 5.5.9+dfsg-1ubuntu4.3
    Published Updated
  13. USN-2254-2

    Not ratedFix available

    php5 updates

    USN-2254-1 fixed vulnerabilities in PHP. The fix for CVE-2014-0185 further restricted the permissions on the PHP FastCGI Process Manager (FPM) UNIX socket. This update grants socket access to the www-data user and group so installations and documentation relying on the previous socket permissions will continue to function. Original advisory details: Christian Hoffmann discovered that the PHP FastCGI Process Manager (FPM) set incorrect permissions on the UNIX socket. A local attacker could use this issue to possibly elevate their privileges. This issue only affected Ubuntu 12.04 LTS, Ubuntu 13.10, and Ubuntu 14.04 LTS. (CVE-2014-0185)

    • Update to 5.5.9+dfsg-1ubuntu4.2
    Published Updated
  14. CVE-2014-4049

    Not ratedEPSS 10.91%Fix available

    CVE-2014-4049

    Heap-based buffer overflow in the php_parserr function in ext/standard/dns.c in PHP 5.6.0beta4 and earlier allows remote servers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted DNS TXT record, related to the dns_get_record function.

    • Update to 5.5.9+dfsg-1ubuntu4.1
    Published Updated
  15. CVE-2014-0238

    Not ratedEPSS 20.8%Fix available

    CVE-2014-0238

    The cdf_read_property_info function in cdf.c in the Fileinfo component in PHP before 5.4.29 and 5.5.x before 5.5.13 allows remote attackers to cause a denial of service (infinite loop or out-of-bounds memory access) via a vector that (1) has zero length or (2) is too long.

    • Update to 5.5.9+dfsg-1ubuntu4.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →