p PatchFirst

PatchFirst · Latest vulnerabilities

firefox vulnerabilities · Page 21

Vulnerabilities published for firefox in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 691

  1. CVE-2018-5108

    Medium · CVSS 4.3EPSS 1.13%Fix available

    CVE-2018-5108

    A Blob URL can violate origin attribute segregation, allowing it to be accessed from a private browsing tab and for data to be passed between the private browsing tab and a normal tab. This could allow for the leaking of private information specific to the private browsing context. This issue is mitigated by the requirement that the user enter the Blob URL manually in order for the access violation to occur. This vulnerability affects Firefox < 58.

    • Update to 58.0+build6-0ubuntu0.16.04.1
    Published Updated
  2. CVE-2018-5107

    Medium · CVSS 5.3EPSS 1.73%Fix available

    CVE-2018-5107

    The printing process can bypass local access protections to read files available through symlinks, bypassing local file restrictions. The printing process requires files in a specific format so arbitrary data cannot be read but it is possible that some local file information could be exposed. This vulnerability affects Firefox < 58.

    • Update to 58.0+build6-0ubuntu0.16.04.1
    Published Updated
  3. CVE-2018-5106

    Medium · CVSS 5.3EPSS 1.25%Fix available

    CVE-2018-5106

    Style editor traffic in the Developer Tools can be routed through a service worker hosted on a third party website if a user selects error links when these tools are open. This can allow style editor information used within Developer Tools to leak cross-origin. This vulnerability affects Firefox < 58.

    • Update to 58.0+build6-0ubuntu0.16.04.1
    Published Updated
  4. CVE-2018-5099

    Critical · CVSS 9.8EPSS 2.97%Fix available

    CVE-2018-5099

    A use-after-free vulnerability can occur when the widget listener is holding strong references to browser objects that have previously been freed, resulting in a potentially exploitable crash when these references are used. This vulnerability affects Thunderbird < 52.6, Firefox ESR < 52.6, and Firefox < 58.

    • Update to 58.0+build6-0ubuntu0.16.04.1
    Published Updated
  5. CVE-2018-5097

    Critical · CVSS 9.8EPSS 7.03%Fix available

    CVE-2018-5097

    A use-after-free vulnerability can occur during XSL transformations when the source document for the transformation is manipulated by script content during the transformation. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 52.6, Firefox ESR < 52.6, and Firefox < 58.

    • Update to 58.0+build6-0ubuntu0.16.04.1
    Published Updated
  6. CVE-2018-5095

    Critical · CVSS 9.8EPSS 4.13%Fix available

    CVE-2018-5095

    An integer overflow vulnerability in the Skia library when allocating memory for edge builders on some systems with at least 8 GB of RAM. This results in the use of uninitialized memory, resulting in a potentially exploitable crash. This vulnerability affects Thunderbird < 52.6, Firefox ESR < 52.6, and Firefox < 58.

    • Update to 58.0+build6-0ubuntu0.16.04.1
    Published Updated
  7. CVE-2018-5089

    Critical · CVSS 9.8EPSS 3.33%Fix available

    CVE-2018-5089

    Memory safety bugs were reported in Firefox 57 and Firefox ESR 52.5. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Thunderbird < 52.6, Firefox ESR < 52.6, and Firefox < 58.

    • Update to 58.0+build6-0ubuntu0.16.04.1
    Published Updated
  8. CVE-2017-7844

    Medium · CVSS 6.5EPSS 1.72%Fix available

    CVE-2017-7844

    A combination of an external SVG image referenced on a page and the coloring of anchor links stored within this image can be used to determine which pages a user has in their history. This can allow a malicious website to query user history. Note: This issue only affects Firefox 57. Earlier releases are not affected. This vulnerability affects Firefox < 57.0.1.

    • Update to 57.0.1+build2-0ubuntu0.16.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →