p PatchFirst

PatchFirst · Latest vulnerabilities

linux-gcp vulnerabilities · Page 22

Vulnerabilities published for linux-gcp in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 655

  1. CVE-2018-18445

    High · CVSS 7.8EPSS 0.54%Fix available

    CVE-2018-18445

    In the Linux kernel 4.14.x, 4.15.x, 4.16.x, 4.17.x, and 4.18.x before 4.18.13, faulty computation of numeric bounds in the BPF verifier permits out-of-bounds memory accesses because adjust_scalar_min_max_vals in kernel/bpf/verifier.c mishandles 32-bit right shifts.

    • Update to 4.15.0-1026.27~16.04.1
    Published Updated
  2. CVE-2018-17972

    Medium · CVSS 5.5EPSS 0.36%Fix available

    CVE-2018-17972

    An issue was discovered in the proc_pid_stack function in fs/proc/base.c in the Linux kernel through 4.18.11. It does not ensure that only root may inspect the kernel stack of an arbitrary task, allowing a local attacker to exploit racy stack unwinding and leak kernel task stack contents.

    • Update to 4.15.0-1027.28~16.04.1
    Published Updated
  3. CVE-2018-14634

    High · CVSS 7.8EPSS 14.69%In KEVPublic exploitFix available

    CVE-2018-14634

    An integer overflow flaw was found in the Linux kernel's create_elf_tables() function. An unprivileged local user with access to SUID (or otherwise privileged) binary could use this flaw to escalate their privileges on the system. Kernel versions 2.6.x, 3.10.x and 4.14.x are believed to be vulnerable.

    • Update to 4.13.0-1002.5
    Published Updated
  4. CVE-2018-14633

    High · CVSS 7EPSS 8.74%Fix available

    CVE-2018-14633

    A security flaw was found in the chap_server_compute_md5() function in the ISCSI target code in the Linux kernel in a way an authentication request from an ISCSI initiator is processed. An unauthenticated remote attacker can cause a stack buffer overflow and smash up to 17 bytes of the stack. The attack requires the iSCSI target to be enabled on the victim host. Depending on how the target's code was built (i.e. depending on a compiler, compile flags and hardware architecture) an attack may lead to a system crash and thus to a denial-of-service or possibly to a non-authorized access to data exported by an iSCSI target. Due to the nature of th

    • Update to 4.15.0-1021.22~16.04.1
    Published Updated
  5. CVE-2018-17182

    High · CVSS 7.8EPSS 3.21%Public exploitFix available

    CVE-2018-17182

    An issue was discovered in the Linux kernel through 4.18.8. The vmacache_flush_all function in mm/vmacache.c mishandles sequence number overflows. An attacker can trigger a use-after-free (and possibly gain privileges) via certain thread creation, map, unmap, invalidation, and dereference operations.

    • Update to 4.15.0-1021.22~16.04.1
    Published Updated
  6. CVE-2018-10853

    High · CVSS 7EPSS 0.47%Fix available

    CVE-2018-10853

    A flaw was found in the way Linux kernel KVM hypervisor before 4.18 emulated instructions such as sgdt/sidt/fxsave/fxrstor. It did not check current privilege(CPL) level while emulating unprivileged instructions. An unprivileged guest user/process could use this flaw to potentially escalate privileges inside guest.

    • Update to 4.15.0-1021.22~16.04.1
    Published Updated
  7. CVE-2018-14625

    Medium · CVSS 5.3EPSS 0.35%Fix available

    CVE-2018-14625

    A flaw was found in the Linux Kernel where an attacker may be able to have an uncontrolled read to kernel-memory from within a vm guest. A race condition between connect() and close() function may allow an attacker using the AF_VSOCK protocol to gather a 4 byte information leak or possibly intercept or corrupt AF_VSOCK messages destined to other clients.

    • Update to 4.15.0-1027.28~16.04.1
    Published Updated
  8. CVE-2018-16658

    Medium · CVSS 6.1EPSS 0.55%Fix available

    CVE-2018-16658

    An issue was discovered in the Linux kernel before 4.18.6. An information leak in cdrom_ioctl_drive_status in drivers/cdrom/cdrom.c could be used by local attackers to read kernel memory because a cast from unsigned long to int interferes with bounds checking. This is similar to CVE-2018-10940.

    • Update to 4.15.0-1024.25~16.04.2
    Published Updated
  9. CVE-2018-5391

    High · CVSS 7.5EPSS 32.45%Fix available

    The Linux kernel, versions 3.9+, IP implementation is vulnerable to denial of service conditions with low rates of specially modified packets

    The Linux kernel, versions 3.9+, is vulnerable to a denial of service attack with low rates of specially modified packets targeting IP fragment re-assembly. An attacker may cause a denial of service condition by sending specially crafted IP fragments. Various vulnerabilities in IP fragmentation have been discovered and fixed over the years. The current vulnerability (CVE-2018-5391) became exploitable in the Linux kernel with the increase of the IP fragment reassembly queue size.

    • Update to 4.15.0-1017.18~16.04.1
    Published Updated
  10. CVE-2018-6555

    High · CVSS 7.8EPSS 0.5%Fix available

    CVE-2018-6555

    The irda_setsockopt function in net/irda/af_irda.c and later in drivers/staging/irda/net/af_irda.c in the Linux kernel before 4.17 allows local users to cause a denial of service (ias_object use-after-free and system crash) or possibly have unspecified other impact via an AF_IRDA socket.

    • Update to 4.15.0-1021.22~16.04.1
    Published Updated
  11. CVE-2018-10938

    Medium · CVSS 5.9EPSS 5%Fix available

    CVE-2018-10938

    A flaw was found in the Linux kernel present since v4.0-rc1 and through v4.13-rc4. A crafted network packet sent remotely by an attacker may force the kernel to enter an infinite loop in the cipso_v4_optptr() function in net/ipv4/cipso_ipv4.c leading to a denial-of-service. A certain non-default configuration of LSM (Linux Security Module) and NetLabel should be set up on a system before an attacker could leverage this flaw.

    • Update to 4.13.0-1002.5
    Published Updated
  12. CVE-2018-10902

    High · CVSS 7.8EPSS 0.52%Fix available

    CVE-2018-10902

    It was found that the raw midi kernel driver does not protect against concurrent access which leads to a double realloc (double free) in snd_rawmidi_input_params() and snd_rawmidi_output_status() which are part of snd_rawmidi_ioctl() handler in rawmidi.c file. A malicious local attacker could possibly use this for privilege escalation.

    • Update to 4.15.0-1026.27~16.04.1
    Published Updated
  13. CVE-2018-15471

    High · CVSS 7.8EPSS 0.33%Fix available

    CVE-2018-15471

    An issue was discovered in xenvif_set_hash_mapping in drivers/net/xen-netback/hash.c in the Linux kernel through 4.18.1, as used in Xen through 4.11.x and other products. The Linux netback driver allows frontends to control mapping of requests to request queues. When processing a request to set or change this mapping, some input validation (e.g., for an integer overflow) was missing or flawed, leading to OOB access in hash handling. A malicious or buggy frontend may cause the (usually privileged) backend to make out of bounds memory accesses, potentially resulting in one or more of privilege escalation, Denial of Service (DoS), or information

    • Update to 4.15.0-1024.25~16.04.2
    Published Updated
  14. CVE-2018-3646

    Medium · CVSS 5.6EPSS 8.1%Fix available

    CVE-2018-3646

    Systems with microprocessors utilizing speculative execution and address translations may allow unauthorized disclosure of information residing in the L1 data cache to an attacker with local user access with guest OS privilege via a terminal page fault and a side-channel analysis.

    • Update to 4.15.0-1017.18~16.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →