p PatchFirst

PatchFirst · Latest vulnerabilities

linux-gke vulnerabilities · Page 3

Vulnerabilities published for linux-gke in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 111

  1. CVE-2017-12134

    High · CVSS 8.8EPSS 0.5%Fix available

    CVE-2017-12134

    The xen_biovec_phys_mergeable function in drivers/xen/biomerge.c in Xen might allow local OS guest users to corrupt block device data streams and consequently obtain sensitive memory information, cause a denial of service, or gain host OS privileges by leveraging incorrect block IO merge-ability calculation.

    • Update to 4.4.0-1032.32
    Published Updated
  2. USN-3392-1

    Not ratedFix available

    linux, linux-aws, linux-gke, linux-raspi2, linux-snapdragon regression

    USN-3378-1 fixed vulnerabilities in the Linux kernel. Unfortunately, a regression was introduced that prevented conntrack from working correctly in some situations. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Fan Wu and Shixiong Zhao discovered a race condition between inotify events and vfs rename operations in the Linux kernel. An unprivileged local attacker could use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2017-7533) It was discovered that the Linux kernel did not properly restrict RLIMIT_STACK size. A local attacker could use this in conju

    • Update to 4.4.0-1027.27
    Published Updated
  3. CVE-2017-12762

    Critical · CVSS 9.8EPSS 5.23%Fix available

    CVE-2017-12762

    In /drivers/isdn/i4l/isdn_net.c: A user-controlled buffer is copied into a local buffer of constant size using strcpy without a length check which can cause a buffer overflow. This affects the Linux kernel 4.9-stable tree, 4.12-stable tree, 3.18-stable tree, and 4.4-stable tree.

    • Update to 4.4.0-1031.31
    Published Updated
  4. CVE-2017-7533

    High · CVSS 7EPSS 1.22%Public exploitFix available

    CVE-2017-7533

    Race condition in the fsnotify implementation in the Linux kernel through 4.12.4 allows local users to gain privileges or cause a denial of service (memory corruption) via a crafted application that leverages simultaneous execution of the inotify_handle_event and vfs_rename functions.

    • Update to 4.4.0-1024.24
    Published Updated
  5. CVE-2017-7541

    High · CVSS 7.8EPSS 0.55%Fix available

    CVE-2017-7541

    The brcmf_cfg80211_mgmt_tx function in drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c in the Linux kernel before 4.12.3 allows local users to cause a denial of service (buffer overflow and system crash) or possibly gain privileges via a crafted NL80211_CMD_FRAME Netlink packet.

    • Update to 4.4.0-1028.28
    Published Updated
  6. CVE-2017-1000363

    High · CVSS 7.8EPSS 0.64%Fix available

    CVE-2017-1000363

    Linux drivers/char/lp.c Out-of-Bounds Write. Due to a missing bounds check, and the fact that parport_ptr integer is static, a 'secure boot' kernel command line adversary (can happen due to bootloader vulns, e.g. Google Nexus 6's CVE-2016-10277, where due to a vulnerability the adversary has partial control over the command line) can overflow the parport_nr array in the following code, by appending many (>LP_NO) 'lp=none' arguments to the command line.

    • Update to 4.4.0-1018.18
    Published Updated
  7. CVE-2017-11176

    High · CVSS 7.8EPSS 3.85%Public exploitFix available

    CVE-2017-11176

    The mq_notify function in the Linux kernel through 4.11.9 does not set the sock pointer to NULL upon entry into the retry logic. During a user-space close of a Netlink socket, it allows attackers to cause a denial of service (use-after-free) or possibly have unspecified other impact.

    • Update to 4.4.0-1028.28
    Published Updated
  8. CVE-2017-10911

    Medium · CVSS 6.5EPSS 0.46%Fix available

    CVE-2017-10911

    The make_response function in drivers/block/xen-blkback/blkback.c in the Linux kernel before 4.11.8 allows guest OS users to obtain sensitive information from host OS (or other guest OS) kernel memory by leveraging the copying of uninitialized padding fields in Xen block-interface response structures, aka XSA-216.

    • Update to 4.4.0-1033.33
    Published Updated
  9. CVE-2017-9985

    High · CVSS 7.8EPSS 0.33%Fix available

    CVE-2017-9985

    The snd_msndmidi_input_read function in sound/isa/msnd/msnd_midi.c in the Linux kernel through 4.11.7 allows local users to cause a denial of service (over-boundary access) or possibly have unspecified other impact by changing the value of a message queue head pointer between two kernel reads of that value, aka a "double fetch" vulnerability.

    • Update to 4.4.0-1033.33
    Published Updated
  10. CVE-2017-9984

    High · CVSS 7.8EPSS 0.38%Fix available

    CVE-2017-9984

    The snd_msnd_interrupt function in sound/isa/msnd/msnd_pinnacle.c in the Linux kernel through 4.11.7 allows local users to cause a denial of service (over-boundary access) or possibly have unspecified other impact by changing the value of a message queue head pointer between two kernel reads of that value, aka a "double fetch" vulnerability.

    • Update to 4.4.0-1033.33
    Published Updated
  11. CVE-2017-1000371

    High · CVSS 7.8EPSS 2.58%Public exploitFix available

    CVE-2017-1000371

    The offset2lib patch as used by the Linux Kernel contains a vulnerability, if RLIMIT_STACK is set to RLIM_INFINITY and 1 Gigabyte of memory is allocated (the maximum under the 1/4 restriction) then the stack will be grown down to 0x80000000, and as the PIE binary is mapped above 0x80000000 the minimum distance between the end of the PIE binary's read-write segment and the start of the stack becomes small enough that the stack guard page can be jumped over by an attacker. This affects Linux Kernel version 4.11.5. This is a different issue than CVE-2017-1000370 and CVE-2017-1000365. This issue appears to be limited to i386 based systems.

    • Update to 4.4.0-1028.28
    Published Updated
  12. CVE-2017-1000370

    High · CVSS 7.8EPSS 2.25%Public exploitFix available

    CVE-2017-1000370

    The offset2lib patch as used in the Linux Kernel contains a vulnerability that allows a PIE binary to be execve()'ed with 1GB of arguments or environmental strings then the stack occupies the address 0x80000000 and the PIE binary is mapped above 0x40000000 nullifying the protection of the offset2lib patch. This affects Linux Kernel version 4.11.5 and earlier. This is a different issue than CVE-2017-1000371. This issue appears to be limited to i386 based systems.

    • Update to 4.4.0-1028.28
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →