p PatchFirst

PatchFirst · Latest vulnerabilities

linux-hwe vulnerabilities · Page 29

Vulnerabilities published for linux-hwe in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 751

  1. CVE-2018-1000026

    High · CVSS 7.7EPSS 4.02%Fix available

    CVE-2018-1000026

    Linux Linux kernel version at least v4.8 onwards, probably well before contains a Insufficient input validation vulnerability in bnx2x network card driver that can result in DoS: Network card firmware assertion takes card off-line. This attack appear to be exploitable via An attacker on a must pass a very large, specially crafted packet to the bnx2x card. This can be done from an untrusted guest VM..

    • Update to 4.13.0-41.46~16.04.1
    Published Updated
  2. CVE-2017-16913

    Medium · CVSS 5.9EPSS 3.93%Fix available

    CVE-2017-16913

    The "stub_recv_cmd_submit()" function (drivers/usb/usbip/stub_rx.c) in the Linux Kernel before version 4.14.8, 4.9.71, and 4.4.114 when handling CMD_SUBMIT packets allows attackers to cause a denial of service (arbitrary memory allocation) via a specially crafted USB over IP packet.

    • Update to 4.15.0-24.26~16.04.1
    Published Updated
  3. USN-3548-2

    Not ratedFix available

    linux-hwe, linux-azure, linux-gcp, linux-oem vulnerability

    USN-3548-1 fixed vulnerabilities in the Linux kernel for Ubuntu 17.10. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 17.10 for Ubuntu 16.04 LTS. Jay Vosburgh discovered a logic error in the x86-64 syscall entry implementation in the Linux kernel, introduced as part of the mitigations for the Spectre vulnerability. A local attacker could use this to cause a denial of service or possibly execute arbitrary code.

    • Update to 4.13.0-32.35~16.04.1
    Published Updated
  4. CVE-2017-18075

    High · CVSS 7.8EPSS 0.4%Fix available

    CVE-2017-18075

    crypto/pcrypt.c in the Linux kernel before 4.14.13 mishandles freeing instances, allowing a local user able to access the AF_ALG-based AEAD interface (CONFIG_CRYPTO_USER_API_AEAD) and pcrypt (CONFIG_CRYPTO_PCRYPT) to cause a denial of service (kfree of an incorrect pointer) or possibly have unspecified other impact by executing a crafted sequence of system calls.

    • Update to 4.15.0-24.26~16.04.1
    Published Updated
  5. CVE-2018-5703

    Critical · CVSS 9.8EPSS 2.63%Fix available

    CVE-2018-5703

    The tcp_v6_syn_recv_sock function in net/ipv6/tcp_ipv6.c in the Linux kernel through 4.14.11 allows attackers to cause a denial of service (slab out-of-bounds write) or possibly have unspecified other impact via vectors involving TLS.

    • Update to 4.15.0-24.26~16.04.1
    Published Updated
  6. CVE-2017-15129

    Medium · CVSS 5.5EPSS 0.36%Fix available

    CVE-2017-15129

    A use-after-free vulnerability was found in network namespaces code affecting the Linux kernel before 4.14.11. The function get_net_ns_by_id() in net/core/net_namespace.c does not check for the net::count value after it has found a peer network in netns_ids idr, which could lead to double free and memory corruption. This vulnerability could allow an unprivileged local user to induce kernel memory corruption on the system, leading to a crash. Due to the nature of the flaw, privilege escalation cannot be fully ruled out, although it is thought to be unlikely.

    • Update to 4.13.0-41.46~16.04.1
    Published Updated
  7. CVE-2017-18017

    Critical · CVSS 9.8EPSS 52.84%Fix available

    CVE-2017-18017

    The tcpmss_mangle_packet function in net/netfilter/xt_TCPMSS.c in the Linux kernel before 4.11, and 4.9.x before 4.9.36, allows remote attackers to cause a denial of service (use-after-free and memory corruption) or possibly have unspecified other impact by leveraging the presence of xt_TCPMSS in an iptables action.

    • Update to 4.13.0-32.35~16.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →